summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2002-11-30 12:40:58 +0000
committerDan Armak <danarmak@gentoo.org>2002-11-30 12:40:58 +0000
commit78eb880b662fe26b57a711c435c6838c22cc26be (patch)
tree6c192660a1c693ce58fb70d812d80ce69665f690 /app-editors/kile
parentreturn libxml2, libxslt deps from = to >= since the broken versions have been... (diff)
downloadhistorical-78eb880b662fe26b57a711c435c6838c22cc26be.tar.gz
historical-78eb880b662fe26b57a711c435c6838c22cc26be.tar.bz2
historical-78eb880b662fe26b57a711c435c6838c22cc26be.zip
Fix #11173: add a patch to enable compiling with a qt that has STL support, fex. our qt 3.1x.
Diffstat (limited to 'app-editors/kile')
-rw-r--r--app-editors/kile/ChangeLog7
-rw-r--r--app-editors/kile/files/kile-1.3-qt-no-stl.diff60
-rw-r--r--app-editors/kile/kile-1.3.ebuild4
3 files changed, 69 insertions, 2 deletions
diff --git a/app-editors/kile/ChangeLog b/app-editors/kile/ChangeLog
index 8a7e360ae6ca..ea546a41bd86 100644
--- a/app-editors/kile/ChangeLog
+++ b/app-editors/kile/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/kile
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/kile/ChangeLog,v 1.6 2002/10/25 21:01:13 hannes Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/kile/ChangeLog,v 1.7 2002/11/30 12:40:52 danarmak Exp $
+
+ 30 Nov 2002; Dan Armak <danarmak@gentoo.org> ChangeLog :
+
+ Fix #11173: add a patch to enable compiling with a qt that has STL support,
+ fex. our qt 3.1x.
*kile-1.3 (25 Oct 2002)
diff --git a/app-editors/kile/files/kile-1.3-qt-no-stl.diff b/app-editors/kile/files/kile-1.3-qt-no-stl.diff
new file mode 100644
index 000000000000..d05dbe3c8a5c
--- /dev/null
+++ b/app-editors/kile/files/kile-1.3-qt-no-stl.diff
@@ -0,0 +1,60 @@
+diff -ur kile/gfe/fileFilter.cpp kile/gfe/fileFilter.cpp
+--- kile/gfe/fileFilter.cpp 2002-10-05 16:13:28.000000000 +0300
++++ kile/gfe/fileFilter.cpp 2002-11-30 13:50:56.000000000 +0200
+@@ -8,6 +8,8 @@
+ *********************************************************************/
+ using namespace std;
+
++#define QT_NO_STL
++
+ #include "fileFilter.h"
+ #include <qstring.h>
+ #include <qfiledlg.h>
+diff -ur kile/gfe/multiFile.cpp kile/gfe/multiFile.cpp
+--- kile/gfe/multiFile.cpp 2002-10-05 16:13:51.000000000 +0300
++++ kile/gfe/multiFile.cpp 2002-11-30 13:50:56.000000000 +0200
+@@ -22,6 +22,8 @@
+
+ ------------------------------------------------------------------------*/
+
++#define QT_NO_STL
++
+ #include "multiFile.h"
+ #include <iostream.h>
+ #include <klocale.h>
+diff -ur kile/gfe/qplotdialog.cpp kile/gfe/qplotdialog.cpp
+--- kile/gfe/qplotdialog.cpp 2002-10-05 16:13:59.000000000 +0300
++++ kile/gfe/qplotdialog.cpp 2002-11-30 13:50:57.000000000 +0200
+@@ -17,6 +17,8 @@
+ * *
+ ***************************************************************************/
+
++#define QT_NO_STL
++
+ #include "qplotdialog.h"
+ #include <qlabel.h>
+ #include <qmenubar.h>
+diff -ur kile/gfe/qplotmaker.cpp kile/gfe/qplotmaker.cpp
+--- kile/gfe/qplotmaker.cpp 2002-10-05 16:14:00.000000000 +0300
++++ kile/gfe/qplotmaker.cpp 2002-11-30 13:50:57.000000000 +0200
+@@ -17,6 +17,8 @@
+ * *
+ ***************************************************************************/
+
++#define QT_NO_STL
++
+ #ifdef HAVE_CONFIG_H
+ #include <config.h>
+ #endif
+diff -ur kile/gfe/rawGnu.cpp kile/gfe/rawGnu.cpp
+--- kile/gfe/rawGnu.cpp 2002-10-05 16:14:02.000000000 +0300
++++ kile/gfe/rawGnu.cpp 2002-11-30 13:50:58.000000000 +0200
+@@ -23,6 +23,8 @@
+
+ *********************************************************************/
+
++#define QT_NO_STL
++
+ #include "rawGnu.h"
+
+ rawGnu::rawGnu
diff --git a/app-editors/kile/kile-1.3.ebuild b/app-editors/kile/kile-1.3.ebuild
index 3b6ebe46d81f..02db4fcac199 100644
--- a/app-editors/kile/kile-1.3.ebuild
+++ b/app-editors/kile/kile-1.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/kile/kile-1.3.ebuild,v 1.2 2002/11/02 09:56:27 hannes Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/kile/kile-1.3.ebuild,v 1.3 2002/11/30 12:40:58 danarmak Exp $
inherit kde-base
need-kde 3
@@ -16,3 +16,5 @@ RDEPEND="${RDEPEND} app-text/tetex"
KEYWORDS="x86"
LICENSE="GPL-2"
+#fix #11173
+PATCHES="$FILESDIR/$P-qt-no-stl.diff"