summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-05-31 22:12:04 +0000
committerMike Frysinger <vapier@gentoo.org>2004-05-31 22:12:04 +0000
commit4559f7b9013ddd83e1078f81640d3fd153a05e4a (patch)
treef0f56511f8ca4be13b2cea17ed70dc40bbedba2a /app-editors/ghex
parentversion bump, first gpg-signed package ;) (diff)
downloadhistorical-4559f7b9013ddd83e1078f81640d3fd153a05e4a.tar.gz
historical-4559f7b9013ddd83e1078f81640d3fd153a05e4a.tar.bz2
historical-4559f7b9013ddd83e1078f81640d3fd153a05e4a.zip
dont install uselss COPYING file and fix other stuff while i'm at it
Diffstat (limited to 'app-editors/ghex')
-rw-r--r--app-editors/ghex/ghex-1.2.1.ebuild37
-rw-r--r--app-editors/ghex/ghex-2.2.1.ebuild18
-rw-r--r--app-editors/ghex/ghex-2.4.0.1.ebuild20
-rw-r--r--app-editors/ghex/ghex-2.4.1.ebuild11
4 files changed, 33 insertions, 53 deletions
diff --git a/app-editors/ghex/ghex-1.2.1.ebuild b/app-editors/ghex/ghex-1.2.1.ebuild
index 58639a0c4637..5ec4fe2db4be 100644
--- a/app-editors/ghex/ghex-1.2.1.ebuild
+++ b/app-editors/ghex/ghex-1.2.1.ebuild
@@ -1,53 +1,40 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/ghex/ghex-1.2.1.ebuild,v 1.13 2003/09/05 23:05:05 msterret Exp $
-
-IUSE="nls"
-
-S=${WORKDIR}/${P}
+# $Header: /var/cvsroot/gentoo-x86/app-editors/ghex/ghex-1.2.1.ebuild,v 1.14 2004/05/31 22:12:03 vapier Exp $
DESCRIPTION="Gnome Hexadecimal editor"
-
+HOMEPAGE="http://pluton.ijs.si/~jaka/gnome.html"
SRC_URI="http://pluton.ijs.si/~jaka/${P}.tar.gz"
-HOMEPAGE="http://pluton.ijs.si/~jaka/gnome.html"
+LICENSE="GPL-2"
+SLOT="1"
+KEYWORDS="x86 ppc sparc"
+IUSE="nls"
RDEPEND="=x11-libs/gtk+-1.2*
>=gnome-base/gnome-libs-1.4.1.2-r3
>=gnome-base/ORBit-0.5.12-r1
>=gnome-base/gnome-print-0.34
>=app-text/scrollkeeper-0.2"
-
DEPEND="${RDEPEND}
nls? ( sys-devel/gettext )"
-SLOT="1"
-LICENSE="GPL-2"
-KEYWORDS="x86 ppc sparc "
-
src_compile() {
-
local myconf=""
-
use nls || myconf="$myconf --disable-nls" #default enabled
- ./configure --host=${CHOST} \
- --prefix=/usr \
- --infodir=/usr/share/info \
- --mandir=/usr/share/man \
- ${myconf} || die "Configuration Failed"
-
+ econf ${myconf} || die
emake || die
}
-src_install () {
- make prefix=${D}/usr \
+src_install() {
+ make \
+ prefix=${D}/usr \
mandir=${D}/usr/share/man \
infodir=${D}/usr/share/info \
GNOME_DATA_DIR=${D}/usr/share \
localstatedir=${D}/var \
install || die "Installation Failed"
- dodoc ABOUT-NLS AUTHORS COPYING COPYING-DOCS ChangeLog INSTALL \
- NEWS README
+ dodoc AUTHORS ChangeLog INSTALL NEWS README
}
diff --git a/app-editors/ghex/ghex-2.2.1.ebuild b/app-editors/ghex/ghex-2.2.1.ebuild
index abfbe6bc4596..6ab782976fc0 100644
--- a/app-editors/ghex/ghex-2.2.1.ebuild
+++ b/app-editors/ghex/ghex-2.2.1.ebuild
@@ -1,27 +1,25 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/ghex/ghex-2.2.1.ebuild,v 1.2 2003/06/29 18:24:08 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/ghex/ghex-2.2.1.ebuild,v 1.3 2004/05/31 22:12:03 vapier Exp $
inherit gnome2
-IUSE="nls"
-S=${WORKDIR}/${P}
DESCRIPTION="Gnome Hexadecimal editor"
HOMEPAGE="http://pluton.ijs.si/~jaka/gnome.html"
+LICENSE="GPL-2 FDL-1.1"
+SLOT="2"
+KEYWORDS="x86"
+IUSE="nls"
+
RDEPEND=">=gnome-base/gail-0.17
>=gnome-base/gconf-1.2
>=gnome-base/libgnomeui-2
>=gnome-base/libglade-2
>=gnome-base/libgnomeprintui-2.2"
-
DEPEND="${RDEPEND}
sys-devel/gettext
dev-util/intltool
>=dev-util/pkgconfig-0.9"
-SLOT="2"
-LICENSE="GPL-2 FDL-1.1"
-KEYWORDS="x86"
-
-DOCS="AUTHORS COPYING* ChangeLog INSTALL NEWS README TODO"
+DOCS="AUTHORS ChangeLog INSTALL NEWS README TODO"
diff --git a/app-editors/ghex/ghex-2.4.0.1.ebuild b/app-editors/ghex/ghex-2.4.0.1.ebuild
index 92b361cdb506..2af942e4fb38 100644
--- a/app-editors/ghex/ghex-2.4.0.1.ebuild
+++ b/app-editors/ghex/ghex-2.4.0.1.ebuild
@@ -1,38 +1,34 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/ghex/ghex-2.4.0.1.ebuild,v 1.4 2004/01/19 12:58:12 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/ghex/ghex-2.4.0.1.ebuild,v 1.5 2004/05/31 22:12:03 vapier Exp $
inherit gnome2
-IUSE=""
DESCRIPTION="Gnome hexadecimal editor"
HOMEPAGE="http://pluton.ijs.si/~jaka/gnome.html"
+LICENSE="GPL-2 FDL-1.1"
+SLOT="2"
+KEYWORDS="x86 sparc"
+IUSE=""
+
RDEPEND=">=gnome-base/gail-0.17
>=x11-libs/gtk+-2
>=dev-libs/atk-1
>=gnome-base/libgnomeui-2
>=gnome-base/libglade-2
>=gnome-base/libgnomeprintui-2.2"
-
DEPEND="${RDEPEND}
app-text/scrollkeeper
dev-util/intltool
>=dev-util/pkgconfig-0.9"
-SLOT="2"
-LICENSE="GPL-2 FDL-1.1"
-KEYWORDS="x86 sparc"
-
-DOCS="AUTHORS COPYING* ChangeLog INSTALL NEWS README TODO"
+DOCS="AUTHORS ChangeLog INSTALL NEWS README TODO"
-MAKEOPTS="-j1"
+MAKEOPTS="${MAKEOPTS} -j1"
src_unpack() {
-
unpack ${A}
-
cd ${S}
gnome2_omf_fix
-
}
diff --git a/app-editors/ghex/ghex-2.4.1.ebuild b/app-editors/ghex/ghex-2.4.1.ebuild
index c8d26e85c902..d4b171941c7e 100644
--- a/app-editors/ghex/ghex-2.4.1.ebuild
+++ b/app-editors/ghex/ghex-2.4.1.ebuild
@@ -1,16 +1,16 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/ghex/ghex-2.4.1.ebuild,v 1.1 2004/02/14 12:56:07 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/ghex/ghex-2.4.1.ebuild,v 1.2 2004/05/31 22:12:03 vapier Exp $
inherit gnome2
DESCRIPTION="Gnome hexadecimal editor"
HOMEPAGE="http://www.gnome.org/softwaremap/projects/ghex/"
-IUSE=""
-SLOT="2"
LICENSE="GPL-2 FDL-1.1"
+SLOT="2"
KEYWORDS="~x86 ~sparc"
+IUSE=""
RDEPEND=">=gnome-base/gail-0.17
>=x11-libs/gtk+-2
@@ -18,15 +18,14 @@ RDEPEND=">=gnome-base/gail-0.17
>=gnome-base/libgnomeui-2
>=gnome-base/libglade-2
>=gnome-base/libgnomeprintui-2.2"
-
DEPEND="${RDEPEND}
app-text/scrollkeeper
dev-util/intltool
>=dev-util/pkgconfig-0.9"
-DOCS="AUTHORS COPYING* ChangeLog INSTALL NEWS README TODO"
+DOCS="AUTHORS ChangeLog INSTALL NEWS README TODO"
-MAKEOPTS="-j1"
+MAKEOPTS="${MAKEOPTS} -j1"
src_unpack() {
unpack ${A}