summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Boeck <hanno@gentoo.org>2003-07-24 18:51:20 +0000
committerHanno Boeck <hanno@gentoo.org>2003-07-24 18:51:20 +0000
commitcbcbeef53503c82b3f83734830a85b6dc305a69c (patch)
tree7f56f1172ec195ae7560e91f02adcaa4bf76b9d5 /app-editors/fte
parentclean up (diff)
downloadhistorical-cbcbeef53503c82b3f83734830a85b6dc305a69c.tar.gz
historical-cbcbeef53503c82b3f83734830a85b6dc305a69c.tar.bz2
historical-cbcbeef53503c82b3f83734830a85b6dc305a69c.zip
added fte executable script.
Diffstat (limited to 'app-editors/fte')
-rw-r--r--app-editors/fte/ChangeLog8
-rw-r--r--app-editors/fte/Manifest5
-rw-r--r--app-editors/fte/files/digest-fte-20020324-r12
-rw-r--r--app-editors/fte/files/fte26
-rw-r--r--app-editors/fte/fte-20020324-r1.ebuild96
5 files changed, 135 insertions, 2 deletions
diff --git a/app-editors/fte/ChangeLog b/app-editors/fte/ChangeLog
index 1d81a0d58520..631e468a35c4 100644
--- a/app-editors/fte/ChangeLog
+++ b/app-editors/fte/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-editors/fte
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/fte/ChangeLog,v 1.14 2003/07/24 17:39:15 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/fte/ChangeLog,v 1.15 2003/07/24 18:51:08 hanno Exp $
+
+*fte-20020324-r1 (24 Jul 2003)
+
+ 24 Jul 2003; Hanno Boeck <hanno@gentoo.org> fte-20020324-r1.ebuild,
+ files/fte:
+ Added fte executable script (from Debian package).
25 Jul 2003; Martin Holzer <mholzer@gentoo.org> fte-20010819-r2.ebuild,
fte-20010819-r3.ebuild, fte-20020324.ebuild:
diff --git a/app-editors/fte/Manifest b/app-editors/fte/Manifest
index 68522c1c7919..6b1f819e0af2 100644
--- a/app-editors/fte/Manifest
+++ b/app-editors/fte/Manifest
@@ -1,8 +1,11 @@
-MD5 f1b7a43b1e69e66a1f1f718f98f86728 ChangeLog 2704
+MD5 ccdaf8f986f79a7b5295fca2d832b4d3 ChangeLog 2871
MD5 908e5073342d358bdfb8fcdde0bbbc6c fte-20010819-r2.ebuild 1779
MD5 63063a8999ac5bb3158665220cbaf4ef fte-20010819-r3.ebuild 1676
MD5 39d3118e1fc62cb244b9dc35945e9673 fte-20020324.ebuild 1868
+MD5 12cd7e88b52d2c559237f07f3c7cd290 fte-20020324-r1.ebuild 1888
+MD5 7c996af2e2e68f96a748f4269c76f710 files/fte 604
MD5 14b0444b3c0e9a62373b4a104b2a8707 files/digest-fte-20010819-r2 133
MD5 14b0444b3c0e9a62373b4a104b2a8707 files/digest-fte-20010819-r3 133
MD5 23d2b8a8749e3a4a9f9ab911641d50e8 files/digest-fte-20020324 133
MD5 71a39685b85b6ccba3d9a8a0dc5ee9bf files/fte-20010819-gentoo.diff 1903
+MD5 23d2b8a8749e3a4a9f9ab911641d50e8 files/digest-fte-20020324-r1 133
diff --git a/app-editors/fte/files/digest-fte-20020324-r1 b/app-editors/fte/files/digest-fte-20020324-r1
new file mode 100644
index 000000000000..26a8064a0c2b
--- /dev/null
+++ b/app-editors/fte/files/digest-fte-20020324-r1
@@ -0,0 +1,2 @@
+MD5 6a0fb80491e4a4edfab0faf8f5a3dc49 fte-20020324-src.zip 625459
+MD5 499b051f6484df3b4f93b43fe9143d0f fte-20020324-common.zip 184928
diff --git a/app-editors/fte/files/fte b/app-editors/fte/files/fte
new file mode 100644
index 000000000000..2e4621b92a62
--- /dev/null
+++ b/app-editors/fte/files/fte
@@ -0,0 +1,26 @@
+#!/bin/sh
+#
+# simple wrapper shell script which selects appropriate fte executable
+#
+
+if [ -n "$DISPLAY" ]; then
+ if which xfte >/dev/null; then
+ exec xfte "$@"
+ elif which sfte >/dev/null; then
+ exec sfte "$@"
+ elif which vfte >/dev/null; then
+ echo "Only Console version installed!"
+ fi
+else
+ if [ "$TERM" = linux ] && which vfte >/dev/null; then
+ exec vfte "$@"
+ elif which sfte >/dev/null; then
+ exec sfte "$@"
+ elif which xfte >/dev/null; then
+ echo "Only X-Window version installed!"
+ fi
+
+fi
+
+echo "No binary executable from the FTE family has been found!"
+echo "Please install one of them."
diff --git a/app-editors/fte/fte-20020324-r1.ebuild b/app-editors/fte/fte-20020324-r1.ebuild
new file mode 100644
index 000000000000..40fe3af3c05a
--- /dev/null
+++ b/app-editors/fte/fte-20020324-r1.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/fte/fte-20020324-r1.ebuild,v 1.1 2003/07/24 18:51:08 hanno Exp $
+
+IUSE="gpm slang X"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Lightweight text-mode editor"
+SRC_URI="mirror://sourceforge/fte/${P}-src.zip
+ mirror://sourceforge/fte/${P}-common.zip"
+HOMEPAGE="http://fte.sourceforge.net"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc"
+
+RDEPEND=">=sys-libs/ncurses-5.2
+ gpm? ( >=sys-libs/gpm-1.20 )"
+
+DEPEND="${RDEPEND}
+ slang? ( sys-libs/slang )
+ app-arch/unzip
+ X? ( virtual/x11 )"
+
+TARGETS=""
+
+if [ "`use slang`" ] ; then
+ TARGETS="${TARGETS} sfte"
+fi
+
+if [ "`use X`" ] ; then
+ TARGETS="${TARGETS} xfte"
+fi
+
+if [ "`use gpm`" ] ; then
+ TARGETS="${TARGETS} vfte"
+fi
+
+src_unpack() {
+
+ cd ${WORKDIR}
+ unpack fte-20020324-src.zip
+ unpack fte-20020324-common.zip
+
+ mv fte fte-20020324
+
+ cd ${S}
+
+ cp src/fte-unix.mak src/fte-unix.mak.orig
+
+ sed \
+ -e "s:@targets@:${TARGETS}:" \
+ -e "s:@cflags@:${CFLAGS}:" \
+ src/fte-unix.mak.orig > src/fte-unix.mak
+}
+
+src_compile() {
+ DEFFLAGS="PREFIX=/usr CONFIGDIR=/usr/share/fte \
+ DEFAULT_FTE_CONFIG=../config/main.fte OPTIMIZE="
+
+ emake $DEFFLAGS TARGETS="$TARGETS" all || die
+
+ cd config
+ ../src/cfte main.fte ../src/system.fterc
+}
+
+src_install () {
+ local files
+ into /usr
+
+ files="${TARGETS} cfte compkeys"
+
+ for i in ${files} ; do
+ dobin src/$i ;
+ done
+
+ dobin ${FILESDIR}/fte
+
+ dodoc Artistic CHANGES BUGS COPYING HISTORY README TODO
+
+ dodir etc/fte
+ cp src/system.fterc ${D}/etc/fte/system.fterc
+
+ dodir usr/share/doc/${P}/html
+ cp doc/INDEX doc/*.html ${D}/usr/share/doc/${P}/html
+
+# if [ -a ${D}/usr/bin/xfte ] ; then
+# into /usr/X11R6 ;
+# dobin src/xfte ;
+# rm ${D}/usr/bin/xfte ;
+# fi
+
+ dodir usr/share/fte
+ cp -R config/* ${D}/usr/share/fte
+ rm -rf ${D}/usr/share/fte/CVS
+}