summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaarten Thibaut <murphy@gentoo.org>2002-05-17 00:36:18 +0000
committerMaarten Thibaut <murphy@gentoo.org>2002-05-17 00:36:18 +0000
commitbdbbfe2da37c7cbea0eb5a8bc1d32f29dbfba456 (patch)
tree7aee4caa2bd12729e01baa027fd80f6731a9dd26 /app-editors/fte
parentFixes #2585. (diff)
downloadhistorical-bdbbfe2da37c7cbea0eb5a8bc1d32f29dbfba456.tar.gz
historical-bdbbfe2da37c7cbea0eb5a8bc1d32f29dbfba456.tar.bz2
historical-bdbbfe2da37c7cbea0eb5a8bc1d32f29dbfba456.zip
Resolves bug 2587 - New version of fte available upstream.
Also implements some general make fixes to obviate the need for patches.
Diffstat (limited to 'app-editors/fte')
-rw-r--r--app-editors/fte/ChangeLog11
-rw-r--r--app-editors/fte/files/digest-fte-200203242
-rw-r--r--app-editors/fte/fte-20020324.ebuild94
3 files changed, 106 insertions, 1 deletions
diff --git a/app-editors/fte/ChangeLog b/app-editors/fte/ChangeLog
index 49e0a2ff8a75..89cacdeec40f 100644
--- a/app-editors/fte/ChangeLog
+++ b/app-editors/fte/ChangeLog
@@ -1,8 +1,17 @@
# ChangeLog for app-editors/fte
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-editors/fte/ChangeLog,v 1.6 2002/05/08 08:43:22 spider Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/fte/ChangeLog,v 1.7 2002/05/17 00:36:18 murphy Exp $
+
+*fte-20020324 (17 May 2002)
+
+ 17 May 2002; M.Thibaut <murphy@gentoo.org> fte-20020324.ebuild :
+
+ New version of FTE released - Resolves bug #2587. Also some changes in
+ the ebuild that should make future releases easier. qfte has been disabled
+ because it doesn't compile.
*fte-20010819-r3 (7 May 2002)
+
7 May 2002; Spider <spider@gentoo.org> fte-20010819-r3.ebuild fte-20010819-r2.ebuild :
fix sourceforge mirroring.
diff --git a/app-editors/fte/files/digest-fte-20020324 b/app-editors/fte/files/digest-fte-20020324
new file mode 100644
index 000000000000..26a8064a0c2b
--- /dev/null
+++ b/app-editors/fte/files/digest-fte-20020324
@@ -0,0 +1,2 @@
+MD5 6a0fb80491e4a4edfab0faf8f5a3dc49 fte-20020324-src.zip 625459
+MD5 499b051f6484df3b4f93b43fe9143d0f fte-20020324-common.zip 184928
diff --git a/app-editors/fte/fte-20020324.ebuild b/app-editors/fte/fte-20020324.ebuild
new file mode 100644
index 000000000000..5f38c95263de
--- /dev/null
+++ b/app-editors/fte/fte-20020324.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Karl Trygve Kalleberg <karltk@gentoo.org>
+# /space/gentoo/cvsroot/gentoo-x86/app-editors/fte/fte-20010819-r3.ebuild,v 1.1 2002/04/27 22:29:37 seemant Exp
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Lightweight text-mode editor"
+SRC_URI="http://unc.dl.sourceforge.net/sourceforge/fte/${P}-src.zip
+ http://telia.dl.sourceforge.net/sourceforge/fte/${P}-src.zip
+ http://telia.dl.sourceforge.net/sourceforge/fte/${P}-src.zip
+
+ http://unc.dl.sourceforge.net/sourceforge/fte/${P}-common.zip
+ http://telia.dl.sourceforge.net/sourceforge/fte/${P}-common.zip
+ http://telia.dl.sourceforge.net/sourceforge/fte/${P}-common.zip"
+HOMEPAGE="http://fte.sourceforge.net"
+
+RDEPEND=">=sys-libs/ncurses-5.2
+ gpm? ( >=sys-libs/gpm-1.20 )"
+
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ X? ( virtual/x11 )"
+
+TARGETS=""
+
+if [ "`use slang`" ] ; then
+ TARGETS="${TARGETS} sfte"
+fi
+
+if [ "`use X`" ] ; then
+ TARGETS="${TARGETS} xfte"
+fi
+
+if [ "`use gpm`" ] ; then
+ TARGETS="${TARGETS} vfte"
+fi
+
+src_unpack() {
+
+ cd ${WORKDIR}
+ unpack fte-20020324-src.zip
+ unpack fte-20020324-common.zip
+
+ mv fte fte-20020324
+
+ cd ${S} # ; patch -p0 < ${FILESDIR}/${PF}-gentoo.diff
+
+ cp src/fte-unix.mak src/fte-unix.mak.orig
+
+ cat src/fte-unix.mak.orig | \
+ sed "s/@targets@/${TARGETS}/" | \
+ sed "s/@cflags@/${CFLAGS}/" \
+ > src/fte-unix.mak
+}
+
+src_compile() {
+ DEFFLAGS="PREFIX=/usr CONFIGDIR=/usr/share/fte \
+ DEFAULT_FTE_CONFIG=../config/main.fte OPTIMIZE="
+
+ emake $DEFFLAGS TARGETS="$TARGETS" all || die
+
+ cd config
+ ../src/cfte main.fte ../src/system.fterc
+}
+
+src_install () {
+ local files
+ into /usr
+
+ files="${TARGETS} cfte compkeys"
+
+ for i in ${files} ; do
+ dobin src/$i ;
+ done
+
+ dodoc Artistic CHANGES BUGS COPYING HISTORY README TODO
+
+ dodir etc/fte
+ cp src/system.fterc ${D}/etc/fte/system.fterc
+
+ dodir usr/share/doc/${P}/html
+ cp doc/INDEX doc/*.html ${D}/usr/share/doc/${P}/html
+
+# if [ -a ${D}/usr/bin/xfte ] ; then
+# into /usr/X11R6 ;
+# dobin src/xfte ;
+# rm ${D}/usr/bin/xfte ;
+# fi
+
+ dodir usr/share/fte
+ cp -R config/* ${D}/usr/share/fte
+ rm -rf ${D}/usr/share/fte/CVS
+}
+