summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Hüttel <dilfridge@gentoo.org>2012-04-08 21:18:49 +0000
committerAndreas Hüttel <dilfridge@gentoo.org>2012-04-08 21:18:49 +0000
commit744827aa1138ad64da905bb87d2417ee130f96bd (patch)
treed54e3f6f6979cfbd45936115ebb792751ac79861 /app-editors/dhex/dhex-0.66.ebuild
parentAlso remove orphan files. (diff)
downloadhistorical-744827aa1138ad64da905bb87d2417ee130f96bd.tar.gz
historical-744827aa1138ad64da905bb87d2417ee130f96bd.tar.bz2
historical-744827aa1138ad64da905bb87d2417ee130f96bd.zip
Version bump
Package-Manager: portage-2.1.10.56/cvs/Linux x86_64
Diffstat (limited to 'app-editors/dhex/dhex-0.66.ebuild')
-rw-r--r--app-editors/dhex/dhex-0.66.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-editors/dhex/dhex-0.66.ebuild b/app-editors/dhex/dhex-0.66.ebuild
new file mode 100644
index 000000000000..5f9f990ff431
--- /dev/null
+++ b/app-editors/dhex/dhex-0.66.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/dhex/dhex-0.66.ebuild,v 1.1 2012/04/08 21:18:49 dilfridge Exp $
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+MY_P=${PN}_${PV}
+
+DESCRIPTION="ncurses-based hex-editor with diff mode"
+HOMEPAGE="http://www.dettus.net/dhex/"
+SRC_URI="http://www.dettus.net/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="sys-libs/ncurses"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-0.63-Makefile.patch"
+}
+
+src_compile() {
+ emake CC=$(tc-getCC)
+}
+
+src_install() {
+ dobin dhex
+ dodoc README.txt
+ doman dhex.1 dhex_markers.5 dhex_searchlog.5 dhexrc.5
+}