summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2005-03-01 10:16:41 +0000
committerDaniel Black <dragonheart@gentoo.org>2005-03-01 10:16:41 +0000
commit92183badf3ce3ba71b761b031151eb73a41af9cb (patch)
treee3354eb17aebd7dc7ca7990f4ba226aad12b3867 /app-crypt/xca/xca-0.5.1.ebuild
parentChanged /var/nagios/rw permissions as per suggested in nagios manual to 2770. (diff)
downloadhistorical-92183badf3ce3ba71b761b031151eb73a41af9cb.tar.gz
historical-92183badf3ce3ba71b761b031151eb73a41af9cb.tar.bz2
historical-92183badf3ce3ba71b761b031151eb73a41af9cb.zip
Initial import as per bug #73955
Package-Manager: portage-2.0.51.17
Diffstat (limited to 'app-crypt/xca/xca-0.5.1.ebuild')
-rw-r--r--app-crypt/xca/xca-0.5.1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/app-crypt/xca/xca-0.5.1.ebuild b/app-crypt/xca/xca-0.5.1.ebuild
new file mode 100644
index 000000000000..a9307e05935d
--- /dev/null
+++ b/app-crypt/xca/xca-0.5.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/xca/xca-0.5.1.ebuild,v 1.1 2005/03/01 10:16:40 dragonheart Exp $
+
+inherit eutils kde toolchain-funcs
+
+DESCRIPTION="a graphical user interface to OpenSSL, RSA public keys, certificates, signing requests and revokation lists"
+HOMEPAGE="http://www.hohnstaedt.de/xca.html"
+SRC_URI="mirror://sourceforge/xca/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND=">=dev-libs/openssl-0.9.6
+ >=x11-libs/qt-2.2.4
+ >=db-3.2"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-qt.diff
+ epatch ${FILESDIR}/configure-db-4.1.patch
+ echo "inst_prefix=/usr" >> Local.mak
+ epatch ${FILESDIR}/Rules.mak-prefix.patch
+}
+
+src_compile() {
+ kde_src_compile nothing
+ CC=$(tc-getCC) prefix=/usr ./configure || die "configure died"
+ inst_prefix=/usr emake || die "emake failed"
+}
+
+src_install() {
+ make destdir=${D} mandir=share/man install
+
+ dodoc README CREDITS AUTHORS COPYRIGHT
+
+ insinto /etc/xca
+ doins misc/*.txt
+}