summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2004-04-18 19:07:22 +0000
committerMamoru Komachi <usata@gentoo.org>2004-04-18 19:07:22 +0000
commit02d6f7543bea4a7af3246658e341717ec99b5bd5 (patch)
tree152c0ba7ef3f0e41539e798f223926fc34176cf6 /app-benchmarks
parentmake sure tux works when system doesnt have jade #48198 (diff)
downloadhistorical-02d6f7543bea4a7af3246658e341717ec99b5bd5.tar.gz
historical-02d6f7543bea4a7af3246658e341717ec99b5bd5.tar.bz2
historical-02d6f7543bea4a7af3246658e341717ec99b5bd5.zip
Initial import. Ebuild submitted by Eric Ball <me@ericball.id.au>, closing bug #18854
Diffstat (limited to 'app-benchmarks')
-rw-r--r--app-benchmarks/pipebench/ChangeLog10
-rw-r--r--app-benchmarks/pipebench/Manifest3
-rw-r--r--app-benchmarks/pipebench/files/digest-pipebench-0.401
-rw-r--r--app-benchmarks/pipebench/pipebench-0.40.ebuild41
4 files changed, 55 insertions, 0 deletions
diff --git a/app-benchmarks/pipebench/ChangeLog b/app-benchmarks/pipebench/ChangeLog
new file mode 100644
index 000000000000..2d75d051da8c
--- /dev/null
+++ b/app-benchmarks/pipebench/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-benchmarks/pipebench
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/pipebench/ChangeLog,v 1.1 2004/04/18 19:07:22 usata Exp $
+
+*pipebench-0.40 (19 Apr 2004)
+
+ 19 Apr 2004; Mamoru KOMACHI <usata@gentoo.org> pipebench-0.40.ebuild:
+ Initial import. Ebuild submitted by Eric Ball <me@ericball.id.au>,
+ closing bug #18854.
+
diff --git a/app-benchmarks/pipebench/Manifest b/app-benchmarks/pipebench/Manifest
new file mode 100644
index 000000000000..c4c20908e483
--- /dev/null
+++ b/app-benchmarks/pipebench/Manifest
@@ -0,0 +1,3 @@
+MD5 24cef732e888092f037f80e6e7ab6647 pipebench-0.40.ebuild 1005
+MD5 8be0ca9284f70c700811851d8b2f8004 ChangeLog 424
+MD5 f5c420076e6845e62a7e78e1595050fb files/digest-pipebench-0.40 65
diff --git a/app-benchmarks/pipebench/files/digest-pipebench-0.40 b/app-benchmarks/pipebench/files/digest-pipebench-0.40
new file mode 100644
index 000000000000..8897ebff871f
--- /dev/null
+++ b/app-benchmarks/pipebench/files/digest-pipebench-0.40
@@ -0,0 +1 @@
+MD5 eb1b888ec6c413c2cb096ac052174a78 pipebench-0.40.tar.gz 11542
diff --git a/app-benchmarks/pipebench/pipebench-0.40.ebuild b/app-benchmarks/pipebench/pipebench-0.40.ebuild
new file mode 100644
index 000000000000..8c666cdbc3a4
--- /dev/null
+++ b/app-benchmarks/pipebench/pipebench-0.40.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/pipebench/pipebench-0.40.ebuild,v 1.1 2004/04/18 19:07:22 usata Exp $
+
+DESCRIPTION="Measures the speed of stdin/stdout communication"
+
+HOMEPAGE="http://www.habets.pp.se/synscan/programs.php?prog=pipebench"
+
+SRC_URI="ftp://ftp.habets.pp.se/pub/synscan/${P}.tar.gz"
+
+LICENSE="GPL-2"
+
+SLOT="0"
+
+KEYWORDS="~x86"
+
+IUSE=""
+
+DEPEND="virtual/glibc"
+
+#Add make.conf CFLAGS, add the ${D} and fix the install dirs here (no /.configure).
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd ${S} || die "Manual configure failed"
+ cp Makefile Makefile.orig
+ sed \
+ -e "s:CFLAGS=-Wall:CFLAGS=${CFLAGS} -Wall:" \
+ -e "s:/usr/local/bin/:${D}/usr/bin:" \
+ -e "s:/usr/local/man/man1/:${D}/usr/share/man/man1:" \
+ Makefile.orig > Makefile
+}
+
+src_compile() {
+ make || die
+}
+
+src_install() {
+ dodir /usr/{bin,share/man/man1}
+ make install || die
+ dodoc README LICENSE
+}