summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2008-10-23 02:43:22 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2008-10-23 02:43:22 +0000
commit1260794d6f6eecd7b6fda8efa8abb4f026657391 (patch)
treeb480cc8cfd337a56eb38dcceefb49ca7e5993eca /app-arch
parentRespect CFLAGS, LDFLAGS and CC. (diff)
downloadhistorical-1260794d6f6eecd7b6fda8efa8abb4f026657391.tar.gz
historical-1260794d6f6eecd7b6fda8efa8abb4f026657391.tar.bz2
historical-1260794d6f6eecd7b6fda8efa8abb4f026657391.zip
Respect CC.
Package-Manager: portage-2.2_rc12/cvs/Linux 2.6.27-gentoo x86_64
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/funzix/ChangeLog5
-rw-r--r--app-arch/funzix/funzix-1.0.ebuild8
-rw-r--r--app-arch/pure-sfv/ChangeLog7
-rw-r--r--app-arch/pure-sfv/pure-sfv-0.3.ebuild10
4 files changed, 24 insertions, 6 deletions
diff --git a/app-arch/funzix/ChangeLog b/app-arch/funzix/ChangeLog
index 6c267adc5fe3..4e94d96225db 100644
--- a/app-arch/funzix/ChangeLog
+++ b/app-arch/funzix/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-arch/funzix
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/funzix/ChangeLog,v 1.3 2008/04/20 06:07:12 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/funzix/ChangeLog,v 1.4 2008/10/23 02:38:38 flameeyes Exp $
+
+ 23 Oct 2008; Diego Pettenò <flameeyes@gentoo.org> funzix-1.0.ebuild:
+ Respect CC.
20 Apr 2008; Mike Frysinger <vapier@gentoo.org> funzix-1.0.ebuild:
Mark amd64 stable #214961.
diff --git a/app-arch/funzix/funzix-1.0.ebuild b/app-arch/funzix/funzix-1.0.ebuild
index a29c115fed4b..29dc2b29d89f 100644
--- a/app-arch/funzix/funzix-1.0.ebuild
+++ b/app-arch/funzix/funzix-1.0.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/funzix/funzix-1.0.ebuild,v 1.3 2008/04/20 06:07:12 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/funzix/funzix-1.0.ebuild,v 1.4 2008/10/23 02:38:38 flameeyes Exp $
+
+inherit toolchain-funcs
DESCRIPTION="unpacker for the bogus ZIX format"
HOMEPAGE="http://funzix.sourceforge.net/"
@@ -11,6 +13,10 @@ SLOT="0"
KEYWORDS="amd64 x86"
IUSE=""
+src_compile() {
+ emake CC="$(tc-getCC)" || die "emake failed"
+}
+
src_install() {
dobin funzix || die
dodoc README
diff --git a/app-arch/pure-sfv/ChangeLog b/app-arch/pure-sfv/ChangeLog
index f769e47cca75..6f9631894e00 100644
--- a/app-arch/pure-sfv/ChangeLog
+++ b/app-arch/pure-sfv/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-arch/pure-sfv
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/pure-sfv/ChangeLog,v 1.10 2007/02/21 20:00:40 peper Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/pure-sfv/ChangeLog,v 1.11 2008/10/23 02:43:22 flameeyes Exp $
+
+ 23 Oct 2008; Diego Pettenò <flameeyes@gentoo.org> pure-sfv-0.3.ebuild:
+ Respect CC.
21 Feb 2007; Piotr Jaroszyński <peper@gentoo.org> ChangeLog:
Transition to Manifest2.
diff --git a/app-arch/pure-sfv/pure-sfv-0.3.ebuild b/app-arch/pure-sfv/pure-sfv-0.3.ebuild
index 506fa1aceea6..0f01003968b6 100644
--- a/app-arch/pure-sfv/pure-sfv-0.3.ebuild
+++ b/app-arch/pure-sfv/pure-sfv-0.3.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/pure-sfv/pure-sfv-0.3.ebuild,v 1.13 2006/01/29 07:36:29 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/pure-sfv/pure-sfv-0.3.ebuild,v 1.14 2008/10/23 02:43:22 flameeyes Exp $
+
+inherit toolchain-funcs
DESCRIPTION="utility to test and create .sfv files and create .par files"
HOMEPAGE="http://pure-sfv.sourceforge.net/"
@@ -22,6 +24,10 @@ src_unpack() {
sed -i 's:-O2 -g::;s:-Werror::' Makefile
}
+src_compile() {
+ emake CC="$(tc_getCC)" || die "emake failed"
+}
+
src_install() {
dobin pure-sfv || die
dodoc ReadMe.txt