summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2002-11-08 13:32:48 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2002-11-08 13:32:48 +0000
commit13fb87907973d0a797c51e67a8664c4d2e247993 (patch)
tree1bc8754aa48d1937324680d39e012afe678b22fc /app-admin
parentFHS fix (diff)
downloadhistorical-13fb87907973d0a797c51e67a8664c4d2e247993.tar.gz
historical-13fb87907973d0a797c51e67a8664c4d2e247993.tar.bz2
historical-13fb87907973d0a797c51e67a8664c4d2e247993.zip
Initial import
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/sxid/ChangeLog8
-rw-r--r--app-admin/sxid/files/digest-sxid-4.0.21
-rw-r--r--app-admin/sxid/sxid-4.0.2.ebuild33
3 files changed, 42 insertions, 0 deletions
diff --git a/app-admin/sxid/ChangeLog b/app-admin/sxid/ChangeLog
new file mode 100644
index 000000000000..c31d066864be
--- /dev/null
+++ b/app-admin/sxid/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for app-admin/sxid
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/sxid/ChangeLog,v 1.1 2002/11/08 13:32:48 aliz Exp $
+
+sxid-4.0.2 (08 Nov 2002)
+
+ 08 Nov 2002; Daniel Ahlberg <aliz@gentoo.org> :
+ Initial import. Ebuild contributed by Cory Visi <cory@visi.name> in #9812.
diff --git a/app-admin/sxid/files/digest-sxid-4.0.2 b/app-admin/sxid/files/digest-sxid-4.0.2
new file mode 100644
index 000000000000..021b9553f1bf
--- /dev/null
+++ b/app-admin/sxid/files/digest-sxid-4.0.2
@@ -0,0 +1 @@
+MD5 feedb01a5e93f8ba9f38a8054f3ef04b sxid_4.0.2.tar.gz 43915
diff --git a/app-admin/sxid/sxid-4.0.2.ebuild b/app-admin/sxid/sxid-4.0.2.ebuild
new file mode 100644
index 000000000000..5121d4482f76
--- /dev/null
+++ b/app-admin/sxid/sxid-4.0.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/sxid/sxid-4.0.2.ebuild,v 1.1 2002/11/08 13:32:48 aliz Exp $
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="suid, sgid file and directory checking"
+SRC_URI="ftp://marcus.seva.net/pub/sxid/${P/-/_}.tar.gz"
+HOMEPAGE="http://freshmeat.net/projects/sxid"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND="virtual/glibc"
+
+src_compile() {
+ # this is an admin application and really requires root to run correctly
+ # we need to move the binary to the sbin directory
+ cd source
+ sed s/bindir/sbindir/g < Makefile.in > Makefile.in.new
+ mv -f Makefile.in.new Makefile.in
+ cd ..
+
+ econf || die "./configure failed"
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc README docs/sxid.conf.example docs/sxid.cron.example
+
+ einfo "You will need to configure sxid.conf for your system using the manpage and example"
+}
+