summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Koltsov <maksbotan@gentoo.org>2011-12-19 13:43:12 +0000
committerMaxim Koltsov <maksbotan@gentoo.org>2011-12-19 13:43:12 +0000
commit203f8050eab50c167e7af40f431072b1edc3237a (patch)
treeb230d70404eb828e0c95aadd65ddacf03e7fe165 /app-admin/stow/stow-2.1.2.ebuild
parentBump to 1.6.4 and EAPI 4, thanks so slepnoga. Bug 394699 (diff)
downloadhistorical-203f8050eab50c167e7af40f431072b1edc3237a.tar.gz
historical-203f8050eab50c167e7af40f431072b1edc3237a.tar.bz2
historical-203f8050eab50c167e7af40f431072b1edc3237a.zip
Bump to 2.1.2, thanks to Erik Falor
Package-Manager: portage-2.1.10.40/cvs/Linux x86_64
Diffstat (limited to 'app-admin/stow/stow-2.1.2.ebuild')
-rw-r--r--app-admin/stow/stow-2.1.2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-admin/stow/stow-2.1.2.ebuild b/app-admin/stow/stow-2.1.2.ebuild
new file mode 100644
index 000000000000..90aff86b46c8
--- /dev/null
+++ b/app-admin/stow/stow-2.1.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/stow/stow-2.1.2.ebuild,v 1.1 2011/12/19 13:43:12 maksbotan Exp $
+
+EAPI="2"
+
+DESCRIPTION="Manage installation of software in /var/lib/"
+HOMEPAGE="http://www.gnu.org/software/stow/"
+SRC_URI="mirror://gnu/stow/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE=""
+
+DEPEND="dev-lang/perl"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+
+ # create new STOWDIR
+ dodir /var/lib/stow
+
+ # install env.d file to add STOWDIR to PATH and LDPATH
+ doenvd "${FILESDIR}"/99stow || die "doenvd failed"
+}
+
+pkg_postinst() {
+ elog "We now recommend that you use /var/lib/stow as your STOWDIR"
+ elog "instead of /usr/local in order to avoid conflicts with the"
+ elog "symlink from /usr/lib64 -> /usr/lib. See Bug 246264 for"
+ elog "more details on this change."
+ elog "For your convenience, PATH has been updated to include"
+ elog "/var/lib/stow/bin."
+}