summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-05-31 22:54:29 +0000
committerMike Frysinger <vapier@gentoo.org>2005-05-31 22:54:29 +0000
commit3bdb5b2ee1e5f7bfd5df64b79bc4260bcb7cad22 (patch)
treed13cb6d06879ecdc08b42396dc26c493b208d316 /app-admin/showconsole
parentmerge fixes from current ~arch ebuild (diff)
downloadhistorical-3bdb5b2ee1e5f7bfd5df64b79bc4260bcb7cad22.tar.gz
historical-3bdb5b2ee1e5f7bfd5df64b79bc4260bcb7cad22.tar.bz2
historical-3bdb5b2ee1e5f7bfd5df64b79bc4260bcb7cad22.zip
integrate blogd with baselayout
Package-Manager: portage-2.0.51.22-r1
Diffstat (limited to 'app-admin/showconsole')
-rw-r--r--app-admin/showconsole/Manifest13
-rw-r--r--app-admin/showconsole/files/bootlogger.sh31
-rw-r--r--app-admin/showconsole/showconsole-1.07.ebuild15
3 files changed, 40 insertions, 19 deletions
diff --git a/app-admin/showconsole/Manifest b/app-admin/showconsole/Manifest
index 73fbf07154fd..10aa9327291a 100644
--- a/app-admin/showconsole/Manifest
+++ b/app-admin/showconsole/Manifest
@@ -1,15 +1,6 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
-MD5 0ba05da928efb267a75d3f8d98e5bad5 showconsole-1.07.ebuild 901
MD5 8c15d2fa20d2097f0b9f2de0485f8182 ChangeLog 565
MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
+MD5 80cb6e11f1927eb7668d35f6c0a8edac showconsole-1.07.ebuild 982
+MD5 d420421077a45ed9cc3b70ee4dc4d177 files/bootlogger.sh 614
MD5 34f6358be961e4385337135c2de859ef files/1.07-no-TIOCGDEV.patch 819
MD5 a081c5c8650672deda68728c8437c846 files/digest-showconsole-1.07 149
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.0 (GNU/Linux)
-
-iD8DBQFCKbWmI1lqEGTUzyQRAm62AKDZMVxenl4q5gu+uLtFwvBx5BSNwgCeOUT7
-ZxgWsX65pDv1lI5c5+FGIuo=
-=1wls
------END PGP SIGNATURE-----
diff --git a/app-admin/showconsole/files/bootlogger.sh b/app-admin/showconsole/files/bootlogger.sh
new file mode 100644
index 000000000000..250bcbf349e5
--- /dev/null
+++ b/app-admin/showconsole/files/bootlogger.sh
@@ -0,0 +1,31 @@
+# /lib/rcscripts/addons/bootlogger.sh: Handle logging of output at boot
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/showconsole/files/bootlogger.sh,v 1.1 2005/05/31 22:54:29 vapier Exp $
+
+if [[ -x /sbin/blogd ]] ; then
+
+bootlog() {
+ local opt=$1
+ shift
+ case ${opt} in
+ start) blogd_start "$@";;
+ sync) blogd_sync "$@";;
+ quit) blogd_quit "$@";;
+ esac
+}
+
+blogd_start() {
+ /sbin/blogd >/dev/null
+}
+
+blogd_sync() {
+ echo > /var/log/boot.msg
+ killall -IO blogd
+}
+
+blogd_quit() {
+ killall -QUIT blogd
+}
+
+fi
diff --git a/app-admin/showconsole/showconsole-1.07.ebuild b/app-admin/showconsole/showconsole-1.07.ebuild
index 20507ea852d4..95a63d1549f5 100644
--- a/app-admin/showconsole/showconsole-1.07.ebuild
+++ b/app-admin/showconsole/showconsole-1.07.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/showconsole/showconsole-1.07.ebuild,v 1.1 2005/03/05 00:38:39 ciaranm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/showconsole/showconsole-1.07.ebuild,v 1.2 2005/05/31 22:54:29 vapier Exp $
inherit eutils toolchain-funcs
@@ -11,19 +11,16 @@ SRC_URI="mirror://gentoo/${P}.tar.bz2
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86"
+KEYWORDS="~amd64 ~x86"
IUSE=""
DEPEND=""
-#RDEPEND=""
-
-S=${WORKDIR}/${P}
src_unpack() {
unpack ${P}.tar.bz2
- cd ${S}
- epatch ${DISTDIR}/${P}-suse-update.patch.bz2
- epatch ${FILESDIR}/${PV}-no-TIOCGDEV.patch
+ cd "${S}"
+ epatch "${DISTDIR}"/${P}-suse-update.patch.bz2
+ epatch "${FILESDIR}"/${PV}-no-TIOCGDEV.patch
}
src_compile() {
@@ -32,6 +29,8 @@ src_compile() {
src_install() {
make install DESTDIR="${D}" || die "install failed"
+ insinto /$(get_libdir)/rcscripts/addons
+ doins "${FILESDIR}"/bootlogger.sh || die "rcscript addon"
rmdir "${D}"/usr/lib/lsb
dodoc showconsole-1.07.lsm README
}