summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Vermeulen <swift@gentoo.org>2011-08-19 17:16:46 +0000
committerSven Vermeulen <swift@gentoo.org>2011-08-19 17:16:46 +0000
commit4ddc837195224d3e39620238c57b18b483931f56 (patch)
treea521362fb0526876d5fd192bd771d0658f1a8ddb /app-admin/setools/files
parentx86 stable wrt security bug #378815 (diff)
downloadhistorical-4ddc837195224d3e39620238c57b18b483931f56.tar.gz
historical-4ddc837195224d3e39620238c57b18b483931f56.tar.bz2
historical-4ddc837195224d3e39620238c57b18b483931f56.zip
Fix bug #378943 - setools-3.3.7 fails to build with new selinux userspace utilities (libsepol-2.1.0)
Package-Manager: portage-2.1.10.3/cvs/Linux x86_64
Diffstat (limited to 'app-admin/setools/files')
-rw-r--r--app-admin/setools/files/fix-check-role_set_expand-libsepol-2.1.0.patch24
-rw-r--r--app-admin/setools/files/fix-implicit-def-fstat.patch13
2 files changed, 37 insertions, 0 deletions
diff --git a/app-admin/setools/files/fix-check-role_set_expand-libsepol-2.1.0.patch b/app-admin/setools/files/fix-check-role_set_expand-libsepol-2.1.0.patch
new file mode 100644
index 000000000000..548f60b7dc88
--- /dev/null
+++ b/app-admin/setools/files/fix-check-role_set_expand-libsepol-2.1.0.patch
@@ -0,0 +1,24 @@
+diff -ur setools-3.3.7.orig/configure.ac setools-3.3.7/configure.ac
+--- setools-3.3.7.orig/configure.ac 2011-08-12 19:20:32.651000078 +0200
++++ setools-3.3.7/configure.ac 2011-08-12 19:20:42.224000036 +0200
+@@ -503,7 +503,7 @@
+ [AC_LANG_SOURCE([
+ #include <sepol/policydb/expand.h>
+ int main () {
+- return role_set_expand(NULL, NULL, NULL, NULL);
++ return role_set_expand(NULL, NULL, NULL, NULL, NULL);
+ }])],
+ sepol_new_user_role_mapping="yes",
+ sepol_new_user_role_mapping="no")
+diff -ur setools-3.3.7.orig/libqpol/src/policy_define.c setools-3.3.7/libqpol/src/policy_define.c
+--- setools-3.3.7.orig/libqpol/src/policy_define.c 2011-08-12 19:20:32.657000013 +0200
++++ setools-3.3.7/libqpol/src/policy_define.c 2011-08-12 19:20:53.907005864 +0200
+@@ -2133,7 +2133,7 @@
+
+ /* This ebitmap business is just to ensure that there are not conflicting role_trans rules */
+ #ifdef HAVE_SEPOL_USER_ROLE_MAPPING
+- if (role_set_expand(&roles, &e_roles, policydbp, NULL))
++ if (role_set_expand(&roles, &e_roles, policydbp, NULL, NULL))
+ #else
+ if (role_set_expand(&roles, &e_roles, policydbp))
+ #endif
diff --git a/app-admin/setools/files/fix-implicit-def-fstat.patch b/app-admin/setools/files/fix-implicit-def-fstat.patch
new file mode 100644
index 000000000000..72764320a252
--- /dev/null
+++ b/app-admin/setools/files/fix-implicit-def-fstat.patch
@@ -0,0 +1,13 @@
+diff -ur setools-3.3.7.orig/libqpol/src/policy.c setools-3.3.7/libqpol/src/policy.c
+--- setools-3.3.7.orig/libqpol/src/policy.c 2011-08-12 19:48:13.793000029 +0200
++++ setools-3.3.7/libqpol/src/policy.c 2011-08-12 19:49:32.880001229 +0200
+@@ -36,6 +36,9 @@
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <sys/mman.h>
++#include <sys/types.h>
++#include <sys/stat.h>
++#include <unistd.h>
+ #include <asm/types.h>
+
+ #include <sepol/debug.h>