summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-11-17 16:39:52 +0000
committerMike Frysinger <vapier@gentoo.org>2004-11-17 16:39:52 +0000
commit7be3021ada355c99c3b6210c9c5aa217c79647b7 (patch)
treed3938da273d3eb92443b3d23c90b67495f1f6ffd /app-admin/procman/procman-1.0.ebuild
parentSome cleanup (diff)
downloadhistorical-7be3021ada355c99c3b6210c9c5aa217c79647b7.tar.gz
historical-7be3021ada355c99c3b6210c9c5aa217c79647b7.tar.bz2
historical-7be3021ada355c99c3b6210c9c5aa217c79647b7.zip
Use make install DESTDIR.
Diffstat (limited to 'app-admin/procman/procman-1.0.ebuild')
-rw-r--r--app-admin/procman/procman-1.0.ebuild19
1 files changed, 10 insertions, 9 deletions
diff --git a/app-admin/procman/procman-1.0.ebuild b/app-admin/procman/procman-1.0.ebuild
index 83745dbabc45..b10a677da354 100644
--- a/app-admin/procman/procman-1.0.ebuild
+++ b/app-admin/procman/procman-1.0.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/procman/procman-1.0.ebuild,v 1.21 2004/06/24 21:35:00 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/procman/procman-1.0.ebuild,v 1.22 2004/11/17 16:39:52 vapier Exp $
+
+inherit flag-o-matic
DESCRIPTION="Process viewer for GNOME"
HOMEPAGE="http://www.personal.psu.edu/kfv101/procman"
@@ -8,7 +10,7 @@ SRC_URI="mirror://gnome/sources/procman/${PV}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86 ppc sparc"
+KEYWORDS="ppc sparc x86"
IUSE="nls"
DEPEND="<gnome-extra/gal-1.99
@@ -16,16 +18,15 @@ DEPEND="<gnome-extra/gal-1.99
RDEPEND="nls? ( sys-devel/gettext )"
src_compile() {
- local myconf
- use nls || myconf="--disable-nls"
-
- CFLAGS="$CFLAGS `gdk-pixbuf-config --cflags`"
- econf --disable-more-warnings ${myconf} || die "econf failed"
-
+ append-flags $(gdk-pixbuf-config --cflags)
+ econf \
+ --disable-more-warnings \
+ $(use_enable nls) \
+ || die "econf failed"
emake || die
}
src_install() {
- einstall || die
+ make install DESTDIR="${D}" || die
dodoc AUTHORS ChangeLog README NEWS TODO
}