summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeonardo Boshell <leonardop@gentoo.org>2005-10-31 16:59:44 +0000
committerLeonardo Boshell <leonardop@gentoo.org>2005-10-31 16:59:44 +0000
commitebfdf113cd15b1fb65cb4c9d027cabcbbdf55042 (patch)
treec39323c6a60acb0957c107c8dd87ae2fd9736d20
parentVersion bumped. (diff)
downloadhistorical-ebfdf113cd15b1fb65cb4c9d027cabcbbdf55042.tar.gz
historical-ebfdf113cd15b1fb65cb4c9d027cabcbbdf55042.tar.bz2
historical-ebfdf113cd15b1fb65cb4c9d027cabcbbdf55042.zip
Fix logic around GTK2_CONFDIR to make the postinst hook work on binary packages.
Package-Manager: portage-2.0.53_rc7
-rw-r--r--x11-libs/gtk+/ChangeLog7
-rw-r--r--x11-libs/gtk+/Manifest16
-rw-r--r--x11-libs/gtk+/gtk+-2.6.10.ebuild26
-rw-r--r--x11-libs/gtk+/gtk+-2.8.6.ebuild22
4 files changed, 41 insertions, 30 deletions
diff --git a/x11-libs/gtk+/ChangeLog b/x11-libs/gtk+/ChangeLog
index 42decdae7377..9ae79f8a8f1c 100644
--- a/x11-libs/gtk+/ChangeLog
+++ b/x11-libs/gtk+/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/gtk+
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/ChangeLog,v 1.193 2005/10/27 21:43:24 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/ChangeLog,v 1.194 2005/10/31 16:59:44 leonardop Exp $
+
+ 31 Oct 2005; Leonardo Boshell <leonardop@gentoo.org> gtk+-2.6.10.ebuild,
+ gtk+-2.8.6.ebuild:
+ Fix logic around GTK2_CONFDIR to make the postinst hook work on binary
+ packages.
27 Oct 2005; Diego Pettenò <flameeyes@gentoo.org>
+files/gtk+-2.8.6-freebsd.patch, gtk+-2.8.6.ebuild:
diff --git a/x11-libs/gtk+/Manifest b/x11-libs/gtk+/Manifest
index c0b6ab0a0f69..3d8e0d73bd13 100644
--- a/x11-libs/gtk+/Manifest
+++ b/x11-libs/gtk+/Manifest
@@ -1,7 +1,4 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
-MD5 0661cfe00a1276ed83d65596869b023a ChangeLog 27709
+MD5 02f976cf189ac711116c0611c437fc39 ChangeLog 27891
MD5 621a7db3e7e6856c66eec5caeea1e88e files/digest-gtk+-1.2.10-r10 138
MD5 621a7db3e7e6856c66eec5caeea1e88e files/digest-gtk+-1.2.10-r11 138
MD5 f56b08a8f40b528e72b6406ea337c51c files/digest-gtk+-2.6.10 212
@@ -16,14 +13,7 @@ MD5 88f458873590e6a355d2bcb76fa859f7 files/gtk+-2.8.6-freebsd.patch 507
MD5 36d00cf3b4035e6cb9873ade9ed1a9ce files/gtkrc 627
MD5 afb0e5aa8f6410c088c2e177a17efe5d gtk+-1.2.10-r10.ebuild 1719
MD5 88d6d5cc6a5a4f0e0426646667134046 gtk+-1.2.10-r11.ebuild 1831
-MD5 7facb5274a3cb2576a7ef26c1d24f0cb gtk+-2.6.10.ebuild 2870
+MD5 33226247e252747686bf5d1a92363808 gtk+-2.6.10.ebuild 2970
MD5 5033b22f68c770cc1738680edc951abf gtk+-2.6.8.ebuild 2884
-MD5 08ec9bef4408c4aac885091eb6c21450 gtk+-2.8.6.ebuild 3470
+MD5 d38317657c696b42dccf01cd12309530 gtk+-2.8.6.ebuild 3935
MD5 58b5c1a403ab43f5160c44c32761cbe0 metadata.xml 424
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.2 (GNU/Linux)
-
-iD8DBQFDYUoYj5H05b2HAEkRAsnkAJ4t5HUBYMDklCw9NYWrbWIrKFh/wQCgmrGA
-V3E2OYsRZiOu6gPAQfxFNcM=
-=yCyF
------END PGP SIGNATURE-----
diff --git a/x11-libs/gtk+/gtk+-2.6.10.ebuild b/x11-libs/gtk+/gtk+-2.6.10.ebuild
index b6f19f878fc1..d44d4b7771f5 100644
--- a/x11-libs/gtk+/gtk+-2.6.10.ebuild
+++ b/x11-libs/gtk+/gtk+-2.6.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/gtk+-2.6.10.ebuild,v 1.3 2005/10/22 15:11:38 nigoro Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/gtk+-2.6.10.ebuild,v 1.4 2005/10/31 16:59:44 leonardop Exp $
inherit flag-o-matic eutils
@@ -30,16 +30,18 @@ DEPEND="${RDEPEND}
>=sys-devel/automake-1.7.9
doc? ( >=dev-util/gtk-doc-1 )"
-# An arch specific config directory is used on multilib systems
-has_multilib_profile && GTK2_CONFDIR="/etc/gtk-2.0/${CHOST}"
-use x86 && [ "$(get_libdir)" == "lib32" ] && GTK2_CONFDIR="/etc/gtk-2.0/${CHOST}"
-GTK2_CONFDIR=${GTK2_CONFDIR:=/etc/gtk-2.0/}
-src_unpack() {
+set_gtk2_confdir() {
+ # An arch specific config directory is used on multilib systems
+ has_multilib_profile && GTK2_CONFDIR="/etc/gtk-2.0/${CHOST}"
+ use x86 && [ "$(get_libdir)" == "lib32" ] && GTK2_CONFDIR="/etc/gtk-2.0/${CHOST}"
+ GTK2_CONFDIR=${GTK2_CONFDIR:=/etc/gtk-2.0}
+}
+src_unpack() {
unpack ${A}
-
cd ${S}
+
# beautifying patch for disabled icons
epatch ${FILESDIR}/${PN}-2.2.1-disable_icons_smooth_alpha.patch
# add smoothscroll support for usability reasons
@@ -86,8 +88,9 @@ src_compile() {
}
src_install() {
-
+ set_gtk2_confdir
dodir ${GTK2_CONFDIR}
+ keepdir ${GTK2_CONFDIR}
make DESTDIR=${D} install || die
@@ -96,12 +99,11 @@ src_install() {
echo "GDK_USE_XFT=1" >${D}/etc/env.d/50gtk2
dodoc AUTHORS ChangeLog* HACKING NEWS* README*
-
}
pkg_postinst() {
+ set_gtk2_confdir
- gtk-query-immodules-2.0 > /${GTK2_CONFDIR}/gtk.immodules
- gdk-pixbuf-query-loaders > /${GTK2_CONFDIR}/gdk-pixbuf.loaders
-
+ gtk-query-immodules-2.0 > ${ROOT}${GTK2_CONFDIR}/gtk.immodules
+ gdk-pixbuf-query-loaders > ${ROOT}${GTK2_CONFDIR}/gdk-pixbuf.loaders
}
diff --git a/x11-libs/gtk+/gtk+-2.8.6.ebuild b/x11-libs/gtk+/gtk+-2.8.6.ebuild
index c4c6f95bd42b..d60cfb028fba 100644
--- a/x11-libs/gtk+/gtk+-2.8.6.ebuild
+++ b/x11-libs/gtk+/gtk+-2.8.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/gtk+-2.8.6.ebuild,v 1.3 2005/10/27 21:43:24 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/gtk+-2.8.6.ebuild,v 1.4 2005/10/31 16:59:44 leonardop Exp $
inherit gnome.org flag-o-matic eutils debug
@@ -52,7 +52,8 @@ DEPEND="${RDEPEND}
>=dev-util/gtk-doc-1.4
~app-text/docbook-xml-dtd-4.1.2 )"
-pkg_setup() {
+
+set_gtk2_confdir() {
# An arch specific config directory is used on multilib systems
has_multilib_profile && GTK2_CONFDIR="/etc/gtk-2.0/${CHOST}"
use x86 && [ "$(get_libdir)" == "lib32" ] && GTK2_CONFDIR="/etc/gtk-2.0/${CHOST}"
@@ -112,7 +113,9 @@ src_compile() {
src_install() {
make DESTDIR="${D}" install || die "Installation failed"
+ set_gtk2_confdir
dodir ${GTK2_CONFDIR}
+ keepdir ${GTK2_CONFDIR}
# Enable xft in environment as suggested by <utx@gentoo.org>
dodir /etc/env.d
@@ -122,6 +125,17 @@ src_install() {
}
pkg_postinst() {
- gtk-query-immodules-2.0 > ${GTK2_CONFDIR}/gtk.immodules
- gdk-pixbuf-query-loaders > ${GTK2_CONFDIR}/gdk-pixbuf.loaders
+ set_gtk2_confdir
+
+ if [ -d "${ROOT}${GTK2_CONFDIR}" ]; then
+ gtk-query-immodules-2.0 > ${ROOT}${GTK2_CONFDIR}/gtk.immodules
+ gdk-pixbuf-query-loaders > ${ROOT}${GTK2_CONFDIR}/gdk-pixbuf.loaders
+ else
+ ewarn "The destination path ${ROOT}${GTK2_CONFDIR} doesn't exist;"
+ ewarn "to complete the installation of GTK+, please create the"
+ ewarn "directory and then manually run:"
+ ewarn " cd ${ROOT}${GTK2_CONFDIR}"
+ ewarn " gtk-query-immodules-2.0 > gtk.immodules"
+ ewarn " gdk-pixbuf-query-loaders > gdk-pixbuf.loaders"
+ fi
}