summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2004-09-15 08:49:55 +0000
committerMamoru Komachi <usata@gentoo.org>2004-09-15 08:49:55 +0000
commite90fb4fdb8ebaf2e487541e5b2d4b089f77d5fcc (patch)
tree8ad800abcead321dbcc31bcace4d83bc0be67b80
parentMake this compile with GCC3.4. (diff)
downloadhistorical-e90fb4fdb8ebaf2e487541e5b2d4b089f77d5fcc.tar.gz
historical-e90fb4fdb8ebaf2e487541e5b2d4b089f77d5fcc.tar.bz2
historical-e90fb4fdb8ebaf2e487541e5b2d4b089f77d5fcc.zip
Version bumped; bug #63624.
-rw-r--r--app-text/xmlto/ChangeLog7
-rw-r--r--app-text/xmlto/Manifest8
-rw-r--r--app-text/xmlto/files/digest-xmlto-0.0.181
-rw-r--r--app-text/xmlto/xmlto-0.0.18.ebuild33
4 files changed, 45 insertions, 4 deletions
diff --git a/app-text/xmlto/ChangeLog b/app-text/xmlto/ChangeLog
index a706c66342b9..900c7632bfd4 100644
--- a/app-text/xmlto/ChangeLog
+++ b/app-text/xmlto/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/xmlto
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/xmlto/ChangeLog,v 1.22 2004/09/08 02:59:17 tgall Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/xmlto/ChangeLog,v 1.23 2004/09/15 08:49:55 usata Exp $
+
+*xmlto-0.0.18 (15 Sep 2004)
+
+ 15 Sep 2004; Mamoru KOMACHI <usata@gentoo.org> +xmlto-0.0.18.ebuild:
+ Version bumped; bug #63624.
07 Sep 2004; Tom Gall <tgall@gentoo.org> xmlto-0.0.17.ebuild:
stable on ppc64
diff --git a/app-text/xmlto/Manifest b/app-text/xmlto/Manifest
index 901dd5f58505..df0dbcdf5d79 100644
--- a/app-text/xmlto/Manifest
+++ b/app-text/xmlto/Manifest
@@ -1,7 +1,9 @@
-MD5 6fb7c6a91f2ce2ec6e44d1b1330ad1ab ChangeLog 3027
-MD5 c472f5fd1646eb8bca71d8df5cb2bdcc metadata.xml 164
MD5 b563453463dfe83c6a92e3ab217b840c xmlto-0.0.15.ebuild 1113
+MD5 3883185809ee51908ab542439d883436 ChangeLog 3158
+MD5 c472f5fd1646eb8bca71d8df5cb2bdcc metadata.xml 164
MD5 715123c30c9eb117d2fb98aaf32606e6 xmlto-0.0.17.ebuild 1063
+MD5 75bcff93f09ec8abe34837c1f84a5892 xmlto-0.0.18.ebuild 987
MD5 1cfec32ebd5d3739c8040ed9cfb1f4ae files/digest-xmlto-0.0.15 64
-MD5 6dcff74be4bd4d52a3ed910aabaa6f63 files/digest-xmlto-0.0.17 64
MD5 f93a45750c50ece36b816d374dde7e28 files/xmlto-head-fix.patch 620
+MD5 6dcff74be4bd4d52a3ed910aabaa6f63 files/digest-xmlto-0.0.17 64
+MD5 cd347c7e58518ba9106284281d3b5aa0 files/digest-xmlto-0.0.18 64
diff --git a/app-text/xmlto/files/digest-xmlto-0.0.18 b/app-text/xmlto/files/digest-xmlto-0.0.18
new file mode 100644
index 000000000000..0df382fad7f5
--- /dev/null
+++ b/app-text/xmlto/files/digest-xmlto-0.0.18
@@ -0,0 +1 @@
+MD5 1a06471b70eb27a6aca5d1b3a144f9b0 xmlto-0.0.18.tar.bz2 91275
diff --git a/app-text/xmlto/xmlto-0.0.18.ebuild b/app-text/xmlto/xmlto-0.0.18.ebuild
new file mode 100644
index 000000000000..248ea0ee72c0
--- /dev/null
+++ b/app-text/xmlto/xmlto-0.0.18.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/xmlto/xmlto-0.0.18.ebuild,v 1.1 2004/09/15 08:49:55 usata Exp $
+
+inherit eutils
+
+DESCRIPTION="A bash script for converting XML and DocBook formatted documents to a variety of output formats"
+HOMEPAGE="http://cyberelk.net/tim/xmlto/"
+SRC_URI="http://cyberelk.net/tim/data/xmlto/stable/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~mips ~alpha ~arm ~amd64 ~ia64 ~ppc64"
+IUSE=""
+
+DEPEND="app-shells/bash
+ dev-libs/libxslt
+ >=app-text/docbook-xsl-stylesheets-1.62.0-r1
+ >=app-text/docbook-xml-dtd-4.2"
+# tetex? ( >=app-text/passivetex-1.4 )"
+# Passivetex/xmltex need some sorting out <obz@gentoo.org>
+
+src_compile() {
+ econf || die
+ emake -j1 || die
+}
+
+src_install() {
+ make DESTDIR=${D} prefix="/usr" install || die
+ dodoc AUTHORS ChangeLog FAQ INSTALL NEWS README
+ insinto /usr/share/doc/${P}/xml
+ doins doc/*.xml
+}