summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNed Ludd <solar@gentoo.org>2003-07-12 17:42:42 +0000
committerNed Ludd <solar@gentoo.org>2003-07-12 17:42:42 +0000
commitc47a7cee3e5f7c9540895af1774b8c3f5821c4e8 (patch)
tree4acbf1e12bb72efbbb047007f7024e543b7ee950
parentgtkmm move x11-libs to dev-cpp (diff)
downloadhistorical-c47a7cee3e5f7c9540895af1774b8c3f5821c4e8.tar.gz
historical-c47a7cee3e5f7c9540895af1774b8c3f5821c4e8.tar.bz2
historical-c47a7cee3e5f7c9540895af1774b8c3f5821c4e8.zip
Added defines for fPIC code to avoid the use the of old __NR* inline assembly construction of syscalls
-rw-r--r--sys-apps/util-linux/ChangeLog9
-rw-r--r--sys-apps/util-linux/Manifest3
-rw-r--r--sys-apps/util-linux/files/digest-util-linux-2.11z-r52
-rw-r--r--sys-apps/util-linux/util-linux-2.11z-r5.ebuild103
4 files changed, 116 insertions, 1 deletions
diff --git a/sys-apps/util-linux/ChangeLog b/sys-apps/util-linux/ChangeLog
index 9abc1c1c188f..30cc84311394 100644
--- a/sys-apps/util-linux/ChangeLog
+++ b/sys-apps/util-linux/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-apps/util-linux
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/ChangeLog,v 1.44 2003/07/06 14:38:03 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/ChangeLog,v 1.45 2003/07/12 17:42:40 solar Exp $
+
+*util-linux-2.11z-r5 (12 Jul 2003)
+
+ 12 Jul 2003; <solar@gentoo.org> util-linux-2.11z-r5.ebuild,
+ files/util-linux-2.11z-pic.patch:
+ Added defines for fPIC code to avoid the use the of old __NR* inline assembly
+ construction of syscalls
05 Jul 2003; Luca Barbato <lu_zero@gentoo.org> util-linux-2.11z-r4.ebuild:
Keyworded ppc
diff --git a/sys-apps/util-linux/Manifest b/sys-apps/util-linux/Manifest
index 639f10b5e729..0560494f9275 100644
--- a/sys-apps/util-linux/Manifest
+++ b/sys-apps/util-linux/Manifest
@@ -1,5 +1,6 @@
MD5 3e53010365b59dade267ca354fbe2ffd ChangeLog 6958
MD5 fdc6f7ebf1e7f279d96f19c330868aa2 util-linux-2.11y.ebuild 2109
+MD5 0cd926897e8b3294ec46d9b721f9386d util-linux-2.11z-r5.ebuild 2706
MD5 b73abbe53ce7a49cad81cc855b7d5924 util-linux-2.11z-r4.ebuild 2410
MD5 48e36b9b6ea3bed4ea25292f9ae5a958 files/digest-util-linux-2.11y 152
MD5 02afa4d774f45ab0b9ef42ecc1748005 files/digest-util-linux-2.11z-r4 153
@@ -9,3 +10,5 @@ MD5 e3697bc8fd6a344e8cba1c7d32e34790 files/util-linux-2.11y-parallel-make.patch
MD5 6dc0134d8d5f325a86257698d2184718 files/util-linux-2.11z-mips-fdisk-fix.patch 1698
MD5 e3697bc8fd6a344e8cba1c7d32e34790 files/util-linux-2.11z-parallel-make.patch 369
MD5 90b5a47385e394b9112357282c35eb4a files/util-linux-2.11z-script.patch 1580
+MD5 18371db840b08f5782e3f8f96c4efe8d files/util-linux-2.11z-pic.patch 3056
+MD5 02afa4d774f45ab0b9ef42ecc1748005 files/digest-util-linux-2.11z-r5 153
diff --git a/sys-apps/util-linux/files/digest-util-linux-2.11z-r5 b/sys-apps/util-linux/files/digest-util-linux-2.11z-r5
new file mode 100644
index 000000000000..b479cd78fc10
--- /dev/null
+++ b/sys-apps/util-linux/files/digest-util-linux-2.11z-r5
@@ -0,0 +1,2 @@
+MD5 abaab0a441233d6b7763b89ea5ab4078 util-linux-2.11z.tar.bz2 1266784
+MD5 9d6c4c8a99188b6696b0735fa48f67c2 util-linux-2.11z-crypt-gentoo.patch.bz2 18249
diff --git a/sys-apps/util-linux/util-linux-2.11z-r5.ebuild b/sys-apps/util-linux/util-linux-2.11z-r5.ebuild
new file mode 100644
index 000000000000..0fbad90a33b8
--- /dev/null
+++ b/sys-apps/util-linux/util-linux-2.11z-r5.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-2.11z-r5.ebuild,v 1.1 2003/07/12 17:42:41 solar Exp $
+
+IUSE="crypt nls static pam"
+
+# hopefully this wont blow us on us on other arches.
+# see below for details on pic.patch
+#inherit eutils flag-o-matic
+#filter-flags -fPIC
+
+S=${WORKDIR}/${P}
+CRYPT_PATCH_P="${P}-crypt-gentoo"
+DESCRIPTION="Various useful Linux utilities"
+SRC_URI="mirror://kernel/linux/utils/${PN}/${P}.tar.bz2
+ crypt? ( mirror://gentoo/${CRYPT_PATCH_P}.patch.bz2 )"
+HOMEPAGE="http://www.kernel.org/pub/linux/utils/util-linux/"
+
+#KEYWORDS="x86 amd64 ppc sparc alpha ~arm mips hppa"
+KEYWORDS="-* ~x86"
+SLOT="0"
+LICENSE="GPL-2"
+
+DEPEND="virtual/glibc
+ >=sys-apps/sed-4.0.5
+ >=sys-libs/ncurses-5.2-r2
+ pam? ( sys-apps/pam-login )"
+
+RDEPEND="${DEPEND} dev-lang/perl
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+
+ if [ ! -z "`use crypt`" ] ; then
+ epatch ${DISTDIR}/${CRYPT_PATCH_P}.patch.bz2
+ fi
+
+ # Fix rare failures with -j4 or higher
+ epatch ${FILESDIR}/${P}-parallel-make.patch
+
+ # Fix unreadable df output
+ epatch ${FILESDIR}/no-symlink-resolve.patch
+
+ # Support the upcoming "script -c COMMAND" feature now.
+ epatch ${FILESDIR}/${P}-script.patch
+
+ # <kumba@gentoo.org> (22 Apr 2003)
+ # Fix fdisk so it works on SGI Disk Labels and lets the user
+ # Actually select a partition, rather than automatically
+ # choosing "4".
+ if [ "${ARCH}" = "mips" ]
+ then
+ epatch ${FILESDIR}/${P}-mips-fdisk-fix.patch
+ fi
+
+ # <solar@gentoo.org> This patch should allow us to remove -fPIC
+ # out of the filter-flags we need this be able to emit position
+ # independent code so we can link our elf executables as shared
+ # objects. "prelink" should now also be able to take advantage
+ epatch ${FILESDIR}/${P}-pic.patch
+
+ #enable pam only if we use it
+ use pam && sed -i "s:HAVE_PAM=no:HAVE_PAM=yes:" MCONFIG
+
+ sed -i \
+ -e "s:-pipe -O2 \$(CPUOPT) -fomit-frame-pointer:${CFLAGS}:" \
+ -e "s:CPU=.*:CPU=${CHOST%%-*}:" \
+ -e "s:HAVE_SLN=no:HAVE_SLN=yes:" \
+ -e "s:HAVE_TSORT=no:HAVE_TSORT=yes:" \
+ -e "s:usr/man:usr/share/man:" \
+ -e "s:usr/info:usr/share/info:" \
+ -e "s:SUIDMODE=.*4755:SUIDMODE=4711:" \
+ MCONFIG || die "MCONFIG sed"
+
+ if [ -z "`use nls`" ] ; then
+ sed -i -e 's/DISABLE_NLS=no/DISABLE_NLS=yes/' MCONFIG ||
+ die "MCONFIG nls sed"
+ fi
+}
+
+src_compile() {
+
+ econf || die "configure failed"
+
+ if [ "`use static`" ] ; then
+ export LDFLAGS=-static
+ fi
+ emake || die "emake failed"
+ cd sys-utils && makeinfo *.texi || die "makeinfo failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "install failed"
+
+ dodoc HISTORY MAINTAINER README VERSION
+ docinto licenses
+ dodoc licenses/* HISTORY
+ docinto examples
+ dodoc example.files/*
+}