summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Walker <ka0ttic@gentoo.org>2004-11-09 16:19:19 +0000
committerAaron Walker <ka0ttic@gentoo.org>2004-11-09 16:19:19 +0000
commitbae2bed3ffe2a86380ba8217d587f9256976278c (patch)
tree8e14a698b240817a4872b651dbf53d7c8a7e6f54
parentsecurity bump. - Format string vulnerability in syslog handling. - bug #69658 (diff)
downloadhistorical-bae2bed3ffe2a86380ba8217d587f9256976278c.tar.gz
historical-bae2bed3ffe2a86380ba8217d587f9256976278c.tar.bz2
historical-bae2bed3ffe2a86380ba8217d587f9256976278c.zip
Updated to use flag-o-matic and toolchain-funcs eclasses; also added static USE flag support (bug #70369).
-rw-r--r--app-shells/ash/ChangeLog6
-rw-r--r--app-shells/ash/Manifest10
-rw-r--r--app-shells/ash/ash-1.6.ebuild16
3 files changed, 19 insertions, 13 deletions
diff --git a/app-shells/ash/ChangeLog b/app-shells/ash/ChangeLog
index ef2d8c12e6e3..c23ba0f1d73b 100644
--- a/app-shells/ash/ChangeLog
+++ b/app-shells/ash/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-shells/ash
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/ash/ChangeLog,v 1.11 2004/10/26 20:29:13 slarti Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/ash/ChangeLog,v 1.12 2004/11/09 16:19:19 ka0ttic Exp $
+
+ 09 Nov 2004; Aaron Walker <ka0ttic@gentoo.org> ash-1.6.ebuild:
+ Updated to use flag-o-matic and toolchain-funcs eclasses; also added static
+ USE flag support (bug #70369).
26 Oct 2004; Tom Martin <slarti@gentoo.org> ash-1.6.ebuild:
Marked ~amd64 for bug 69062.
diff --git a/app-shells/ash/Manifest b/app-shells/ash/Manifest
index ef7ab32edaaa..0293770ca7e6 100644
--- a/app-shells/ash/Manifest
+++ b/app-shells/ash/Manifest
@@ -1,13 +1,13 @@
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
-MD5 42a71de3f720ee670581406e6bd49332 ash-1.6.ebuild 1310
-MD5 672ad4b446461449fd3a83e87b689fd3 ChangeLog 1327
+MD5 49ede0ff642d06381cbae1c01a625dae ash-1.6.ebuild 1411
+MD5 88907bcbd0aa3672a5d5eaa9c8971db1 ChangeLog 1505
MD5 8ae8baf7eab9f0bf48c73e3198ab0ee4 files/digest-ash-1.6 127
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.6 (GNU/Linux)
-iD8DBQFBfqWgCHk4+ZoBpvsRAhdhAKC71dQIhpMyH0bqrN1lcG00E6sOIgCgkfTx
-i8CbiOIbhQ4bucy63EhrlEs=
-=md0n
+iD8DBQFBkO4PEZCkKN40op4RAi86AJ9LP/z1LCvCScdlsdqN3NcSdcVUmACfU3ID
+InnxyaOkQ8jERhklhxuEeXk=
+=sLZz
-----END PGP SIGNATURE-----
diff --git a/app-shells/ash/ash-1.6.ebuild b/app-shells/ash/ash-1.6.ebuild
index 4234bb934895..fdb7da52b9aa 100644
--- a/app-shells/ash/ash-1.6.ebuild
+++ b/app-shells/ash/ash-1.6.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/ash/ash-1.6.ebuild,v 1.15 2004/10/26 20:29:13 slarti Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/ash/ash-1.6.ebuild,v 1.16 2004/11/09 16:19:19 ka0ttic Exp $
-inherit eutils
+inherit eutils flag-o-matic toolchain-funcs
DESCRIPTION="NetBSD's lightweight bourne shell"
HOMEPAGE="http://cvsweb.netbsd.org/bsdweb.cgi/src/bin/sh/"
@@ -13,7 +13,7 @@ SRC_URI="ftp://ftp.netbsd.org/pub/NetBSD/NetBSD-release-1-6/tar_files/src/bin.ta
LICENSE="BSD"
SLOT="0"
KEYWORDS="x86 ~ppc sparc ~mips alpha arm ~amd64"
-IUSE=""
+IUSE="static"
DEPEND="sys-devel/pmake
sys-apps/sed
@@ -29,11 +29,13 @@ src_unpack() {
}
src_compile() {
- # pmake name conflicts, use full path
- /usr/bin/pmake CFLAGS:="-Wall -DBSD=1 -D_GNU_SOURCE -DGLOB_BROKEN \
+ use static && append-ldflags -static
+ append-flags "-Wall -DBSD=1 -D_GNU_SOURCE -DGLOB_BROKEN \
-DHAVE_VASPRINTF=1 -DIFS_BROKEN -DGCC_BROKEN_NG -D__COPYRIGHT\(x\)=\
- -D__RCSID\(x\)= -D_DIAGASSERT\(x\)= -g -O2 -fstrict-aliasing ${CFLAGS}" \
- YACC:="sh ${S}/yaccfe.sh" || die "pmake failed"
+ -D__RCSID\(x\)= -D_DIAGASSERT\(x\)= -fstrict-aliasing"
+ # pmake name conflicts, use full path
+ /usr/bin/pmake CC="$(tc-getCC)" CFLAGS:="${CFLAGS}" \
+ YACC:="sh ${S}/yaccfe.sh" || die "pmake failed"
}
src_install() {