summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Goller <morfic@gentoo.org>2004-08-09 01:58:42 +0000
committerDaniel Goller <morfic@gentoo.org>2004-08-09 01:58:42 +0000
commitb95badd43f9882bcd18640ce5ade98bcaf96db33 (patch)
tree4b5c5144b1c2fed3b044b624bbff1838f42ab9f5
parentchanged `` to $(), the newer bash syntax (diff)
downloadhistorical-b95badd43f9882bcd18640ce5ade98bcaf96db33.tar.gz
historical-b95badd43f9882bcd18640ce5ade98bcaf96db33.tar.bz2
historical-b95badd43f9882bcd18640ce5ade98bcaf96db33.zip
fix gtk and kde USE flags
-rw-r--r--app-sci/celestia/Manifest2
-rw-r--r--app-sci/celestia/celestia-1.3.2_pre20040731-r1.ebuild14
2 files changed, 14 insertions, 2 deletions
diff --git a/app-sci/celestia/Manifest b/app-sci/celestia/Manifest
index 5be8da25899f..ab8012140f87 100644
--- a/app-sci/celestia/Manifest
+++ b/app-sci/celestia/Manifest
@@ -6,7 +6,7 @@ MD5 0f4d71adea6a063dd7b7924cb7b9e095 celestia-1.3.0.ebuild 2099
MD5 14f5cbf8faa7e786b329e9bce9ee9b6c ChangeLog 3740
MD5 8c623e53daafa025137077c6b65815bd metadata.xml 156
MD5 fa6a82f3973d8db6823bda1dcca14677 celestia-1.2.4.ebuild 1193
-MD5 8163e1abd9e3c61fd9f87078bce4f182 celestia-1.3.2_pre20040731-r1.ebuild 2490
+MD5 b474785297fc3ddd34029ce0f9085f11 celestia-1.3.2_pre20040731-r1.ebuild 3152
MD5 4282911b2e0db55c52e0b7b394b21c65 celestia-1.3.2_pre20040731.ebuild 2985
MD5 48aea4af15487f0c322ff982360d7ee8 files/celestia-1.3.1-gtkmain.patch 2501
MD5 f34ba9f68bc1c0e8487c8e27ba984333 files/digest-celestia-1.2.2 68
diff --git a/app-sci/celestia/celestia-1.3.2_pre20040731-r1.ebuild b/app-sci/celestia/celestia-1.3.2_pre20040731-r1.ebuild
index 01a8319e1a6f..5bc487be4b9d 100644
--- a/app-sci/celestia/celestia-1.3.2_pre20040731-r1.ebuild
+++ b/app-sci/celestia/celestia-1.3.2_pre20040731-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/celestia/celestia-1.3.2_pre20040731-r1.ebuild,v 1.1 2004/08/09 01:30:31 morfic Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/celestia/celestia-1.3.2_pre20040731-r1.ebuild,v 1.2 2004/08/09 01:58:42 morfic Exp $
inherit eutils flag-o-matic gnome2
@@ -54,6 +54,18 @@ src_unpack() {
# (http://bugs.gentoo.org/show_bug.cgi?id=53479#c2)
epatch ${FILESDIR}/resmanager.h.patch || die
+ if use !gnome; then
+ # alright this snapshot seems to have some trouble with installing a
+ # file properly. It wants to install celestia.schemas in / which leads
+ # to an ACCESS VIOLATION. Unfortunately this file even gets installed
+ # when no gtk/gnome is enabled
+ # The following lines prevents this but thinkabout as a dirty hack
+ cd ${S}/src/celestia/gtk || die
+ sed -i -e 's:GCONF_SCHEMA_FILE_DIR = @GCONF_SCHEMA_FILE_DIR@:GCONF_SCHEMA_FILE_DIR = $(pkgdatadir)/schemas:g' Makefile.in || die
+ sed -i -e 's:GCONF_SCHEMA_FILE_DIR = @GCONF_SCHEMA_FILE_DIR@:GCONF_SCHEMA_FILE_DIR = $(pkgdatadir)/schemas:g' data/Makefile.in || die
+ cd ${S} || die
+ fi
+
}
src_compile() {