summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2003-02-25 00:03:46 +0000
committerLuca Barbato <lu_zero@gentoo.org>2003-02-25 00:03:46 +0000
commit5082519e2817e25f00130847912cbcc4d8b2e332 (patch)
tree312a68b05416b4e0573ce01befef461b21b83b58
parentmark stable for ARM (diff)
downloadhistorical-5082519e2817e25f00130847912cbcc4d8b2e332.tar.gz
historical-5082519e2817e25f00130847912cbcc4d8b2e332.tar.bz2
historical-5082519e2817e25f00130847912cbcc4d8b2e332.zip
*** empty log message ***
-rw-r--r--media-libs/tse3/ChangeLog8
-rw-r--r--media-libs/tse3/files/digest-tse3-0.2.51
-rw-r--r--media-libs/tse3/tse3-0.2.5.ebuild35
3 files changed, 44 insertions, 0 deletions
diff --git a/media-libs/tse3/ChangeLog b/media-libs/tse3/ChangeLog
new file mode 100644
index 000000000000..a90aa45ba5d5
--- /dev/null
+++ b/media-libs/tse3/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for media-libs/tse3
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/tse3/ChangeLog,v 1.1 2003/02/25 00:03:46 lu_zero Exp $
+
+*tse3-0.2.5 (24 Feb 2003)
+
+ 24 Feb 2003; Luca Barbato <lu_zero@gentoo.org> :
+ Initial import. Ebuild submitted by Michele Balistreri <brain87@gmx.net>. \ No newline at end of file
diff --git a/media-libs/tse3/files/digest-tse3-0.2.5 b/media-libs/tse3/files/digest-tse3-0.2.5
new file mode 100644
index 000000000000..387bb1eb1659
--- /dev/null
+++ b/media-libs/tse3/files/digest-tse3-0.2.5
@@ -0,0 +1 @@
+MD5 0ae6fd5912ba891ff0412b163bc9ce89 tse3-0.2.5.tar.gz 569597
diff --git a/media-libs/tse3/tse3-0.2.5.ebuild b/media-libs/tse3/tse3-0.2.5.ebuild
new file mode 100644
index 000000000000..09cd8c14f4ec
--- /dev/null
+++ b/media-libs/tse3/tse3-0.2.5.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/media-libs/tse3/tse3-0.2.5.ebuild,v 1.1 2003/02/25 00:03:46 lu_zero Exp $
+
+S="${WORKDIR}/tse3-0.2.5"
+IUSE="alsa oss arts"
+DESCRIPTION="TSE3 Sequencer library"
+SRC_URI="mirror://sourceforge/tse3/${P}.tar.gz"
+HOMEPAGE="http://TSE3.sourceforge.net/"
+SLOT="0"
+KEYWORDS="~x86"
+LICENSE="GPL-2"
+
+DEPEND="alsa? ( media-libs/alsa-lib )
+ arts? ( kde-base/arts )"
+
+src_compile() {
+ local myconf=""
+
+ use arts || myconf="$myconf --without-arts"
+ use alsa || myconf="$myconf --without-alsa"
+ use oss || myconf="$myconf --without-oss"
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ $myconf || die "./configure failed"
+ make || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS ChangeLog COPYING INSTALL NEWS README THANKS TODO Version
+}