summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2005-10-08 08:32:25 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2005-10-08 08:32:25 +0000
commit2c7a29f9bd4f5a228d4106f2cc33c8dfa6ef964a (patch)
tree6d65a99e34e012438cf1ddb21ac62b3842f55c9c
parentNew version. Use the 'examples' flag as in x11-libs/qt. (diff)
downloadhistorical-2c7a29f9bd4f5a228d4106f2cc33c8dfa6ef964a.tar.gz
historical-2c7a29f9bd4f5a228d4106f2cc33c8dfa6ef964a.tar.bz2
historical-2c7a29f9bd4f5a228d4106f2cc33c8dfa6ef964a.zip
New upstream version.
Package-Manager: portage-2.0.53_rc4
-rw-r--r--dev-lisp/cl-tbnl/ChangeLog7
-rw-r--r--dev-lisp/cl-tbnl/Manifest12
-rw-r--r--dev-lisp/cl-tbnl/cl-tbnl-0.8.2.ebuild39
-rw-r--r--dev-lisp/cl-tbnl/files/digest-cl-tbnl-0.8.21
4 files changed, 53 insertions, 6 deletions
diff --git a/dev-lisp/cl-tbnl/ChangeLog b/dev-lisp/cl-tbnl/ChangeLog
index f46052264452..d4efc7e7a3d8 100644
--- a/dev-lisp/cl-tbnl/ChangeLog
+++ b/dev-lisp/cl-tbnl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lisp/cl-tbnl
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-tbnl/ChangeLog,v 1.15 2005/09/30 04:29:06 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-tbnl/ChangeLog,v 1.16 2005/10/08 08:32:25 mkennedy Exp $
+
+*cl-tbnl-0.8.2 (08 Oct 2005)
+
+ 08 Oct 2005; Matthew Kennedy <mkennedy@gentoo.org> +cl-tbnl-0.8.2.ebuild:
+ New upstream version.
*cl-tbnl-0.8.1 (30 Sep 2005)
diff --git a/dev-lisp/cl-tbnl/Manifest b/dev-lisp/cl-tbnl/Manifest
index baaf45892bf9..fb168432436d 100644
--- a/dev-lisp/cl-tbnl/Manifest
+++ b/dev-lisp/cl-tbnl/Manifest
@@ -1,14 +1,16 @@
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
-MD5 1b0ecf37915036eec4d70ab58b7bea5c ChangeLog 2777
-MD5 a2199253dbe57d398c785af8f7744485 metadata.xml 804
+MD5 f24bc3a7c667745a1622e9ffe78a855a ChangeLog 2908
MD5 521080973726d201c9d51362d39fb0f9 cl-tbnl-0.8.1.ebuild 1011
+MD5 494049bb4d14805426c66504db3e4d95 cl-tbnl-0.8.2.ebuild 1011
MD5 4dd90dfe84b2196288e5a1d94499189a files/digest-cl-tbnl-0.8.1 66
+MD5 f88112f5ff9bc588b54eb4dafb97837e files/digest-cl-tbnl-0.8.2 66
+MD5 a2199253dbe57d398c785af8f7744485 metadata.xml 804
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (GNU/Linux)
-iD8DBQFDPL9eyiNZaEAZA+ARAsvHAJ0Xxou7wzMQMOGYXi5qynEQFZEIUwCdHdSL
-uMuagp112WhIq+fJJvN8Pu4=
-=LJT6
+iD8DBQFDR4RhyiNZaEAZA+ARAkGIAJ4nYHBUOMtibn+J4cfQxve2VDHfZgCaA/zH
+/XyqAYJkAJLyqQieWkm55pk=
+=PtWM
-----END PGP SIGNATURE-----
diff --git a/dev-lisp/cl-tbnl/cl-tbnl-0.8.2.ebuild b/dev-lisp/cl-tbnl/cl-tbnl-0.8.2.ebuild
new file mode 100644
index 000000000000..5cefc2d78cc6
--- /dev/null
+++ b/dev-lisp/cl-tbnl/cl-tbnl-0.8.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-tbnl/cl-tbnl-0.8.2.ebuild,v 1.1 2005/10/08 08:32:25 mkennedy Exp $
+
+inherit common-lisp
+
+DESCRIPTION="TBNL is a toolkit for building dynamic websites with Common Lisp based on mod_lisp."
+HOMEPAGE="http://www.weitz.de/tbnl/"
+SRC_URI="mirror://gentoo/tbnl_${PV}.orig.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc x86"
+IUSE="standalone"
+
+DEPEND="dev-lisp/cl-kmrcl
+ dev-lisp/cl-md5
+ dev-lisp/cl-base64
+ dev-lisp/cl-url-rewrite
+ dev-lisp/cl-ppcre
+ dev-lisp/cl-rfc2388"
+
+# RDEPEND="${DEPEND}
+# apache2? ( www-apache/mod_lisp2 ) !apache2? ( www-apache/mod_lisp )"
+
+RDEPEND="${DEPEND}
+ !standalone? ( www-apache/mod_lisp )"
+
+S=${WORKDIR}/tbnl-${PV}
+
+CLPACKAGE=tbnl
+
+src_install() {
+ common-lisp-install *.lisp *.asd
+ common-lisp-system-symlink
+ insinto $CLSOURCEROOT/$CLPACKAGE/
+ doins -r test contrib
+ dodoc CHANGELOG README
+ dohtml doc/index.html
+}
diff --git a/dev-lisp/cl-tbnl/files/digest-cl-tbnl-0.8.2 b/dev-lisp/cl-tbnl/files/digest-cl-tbnl-0.8.2
new file mode 100644
index 000000000000..21319c42b636
--- /dev/null
+++ b/dev-lisp/cl-tbnl/files/digest-cl-tbnl-0.8.2
@@ -0,0 +1 @@
+MD5 fc281fe8921edb57f3b9373118c71892 tbnl_0.8.2.orig.tar.gz 86280