summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/tevent/tevent-0.9.26.ebuild')
-rw-r--r--sys-libs/tevent/tevent-0.9.26.ebuild55
1 files changed, 0 insertions, 55 deletions
diff --git a/sys-libs/tevent/tevent-0.9.26.ebuild b/sys-libs/tevent/tevent-0.9.26.ebuild
deleted file mode 100644
index 84748c75001b..000000000000
--- a/sys-libs/tevent/tevent-0.9.26.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 )
-PYTHON_REQ_USE="threads(+)"
-
-inherit waf-utils multilib-minimal python-single-r1
-
-DESCRIPTION="Samba tevent library"
-HOMEPAGE="http://tevent.samba.org/"
-SRC_URI="http://samba.org/ftp/tevent/${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~arm-linux ~x86-linux"
-IUSE="python"
-
-RDEPEND=">=sys-libs/talloc-2.1.5[${MULTILIB_USEDEP}]
- python? ( ${PYTHON_DEPS} )"
-
-DEPEND="${RDEPEND}
- >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]
- ${PYTHON_DEPS}
-"
-# build system does not work with python3
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-WAF_BINARY="${S}/buildtools/bin/waf"
-
-pkg_setup() {
- python-single-r1_pkg_setup
-}
-
-src_prepare() {
- multilib_copy_sources
-}
-
-multilib_src_configure() {
- waf-utils_src_configure \
- $(multilib_native_usex python '' '--disable-python')
-}
-
-multilib_src_compile() {
- # need to avoid parallel building, this looks like the sanest way with waf-utils/multiprocessing eclasses
- unset MAKEOPTS
- waf-utils_src_compile
-}
-
-multilib_src_install() {
- waf-utils_src_install
-
- multilib_is_native_abi && use python && python_domodule tevent.py
-}