summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/llvm-libunwind/llvm-libunwind-11.0.0.9999.ebuild')
-rw-r--r--sys-libs/llvm-libunwind/llvm-libunwind-11.0.0.9999.ebuild7
1 files changed, 7 insertions, 0 deletions
diff --git a/sys-libs/llvm-libunwind/llvm-libunwind-11.0.0.9999.ebuild b/sys-libs/llvm-libunwind/llvm-libunwind-11.0.0.9999.ebuild
index 4f813dc7e2cd..796cfb527602 100644
--- a/sys-libs/llvm-libunwind/llvm-libunwind-11.0.0.9999.ebuild
+++ b/sys-libs/llvm-libunwind/llvm-libunwind-11.0.0.9999.ebuild
@@ -37,6 +37,13 @@ pkg_setup() {
use test && python-any-r1_pkg_setup
}
+src_prepare() {
+ # cmake eclasses suck by forcing ${S} here
+ CMAKE_USE_DIR=${S} \
+ S=${WORKDIR} \
+ cmake-utils_src_prepare
+}
+
multilib_src_configure() {
local libdir=$(get_libdir)