summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-cluster/pmix')
-rw-r--r--sys-cluster/pmix/pmix-5.0.2.ebuild12
1 files changed, 10 insertions, 2 deletions
diff --git a/sys-cluster/pmix/pmix-5.0.2.ebuild b/sys-cluster/pmix/pmix-5.0.2.ebuild
index f7d88d473b4c..204dcf878bff 100644
--- a/sys-cluster/pmix/pmix-5.0.2.ebuild
+++ b/sys-cluster/pmix/pmix-5.0.2.ebuild
@@ -35,9 +35,17 @@ src_configure() {
# https://github.com/openpmix/openpmix/issues/3350
filter-lto
- econf \
- $(use_enable debug) \
+ local myeconfargs=(
+ # These are alternatives. We must use the one in DEPEND, and also
+ # prevent automagic fallbacks.
+ --with-libevent
+ --without-libev
+
+ $(use_enable debug)
$(use_with munge)
+ )
+
+ econf "${myeconfargs[@]}"
}
src_install() {