summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-06-30 21:37:08 -0400
committerEli Schwartz <eschwartz@gentoo.org>2024-07-03 17:24:58 -0400
commit204e818da24baa0bc4a04a8e22d7eb29ffed59e4 (patch)
treeb2c5b01a4cd72e514be3a506755b9d4e474117a2 /sys-cluster/pmix
parentsys-cluster/pmix: stop enabling -Werror via ./configure (diff)
downloadgentoo-204e818da24baa0bc4a04a8e22d7eb29ffed59e4.tar.gz
gentoo-204e818da24baa0bc4a04a8e22d7eb29ffed59e4.tar.bz2
gentoo-204e818da24baa0bc4a04a8e22d7eb29ffed59e4.zip
sys-cluster/pmix: enforce the choice of event library
pmix can be built with either libevent or libev, and we need to depend on the correct one. We depend on libevent. If, somehow, the configure check is broken, it will "happily" attempt to automagically build against libev instead, with varying degrees of success. Make sure it knows which one it MUST pick. Also update to use modern econf passing style with a local array, so that comments are supported! Closes: https://bugs.gentoo.org/884883 Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Eli Schwartz <eschwartz@gentoo.org>
Diffstat (limited to 'sys-cluster/pmix')
-rw-r--r--sys-cluster/pmix/pmix-5.0.2.ebuild12
1 files changed, 10 insertions, 2 deletions
diff --git a/sys-cluster/pmix/pmix-5.0.2.ebuild b/sys-cluster/pmix/pmix-5.0.2.ebuild
index f7d88d473b4c..204dcf878bff 100644
--- a/sys-cluster/pmix/pmix-5.0.2.ebuild
+++ b/sys-cluster/pmix/pmix-5.0.2.ebuild
@@ -35,9 +35,17 @@ src_configure() {
# https://github.com/openpmix/openpmix/issues/3350
filter-lto
- econf \
- $(use_enable debug) \
+ local myeconfargs=(
+ # These are alternatives. We must use the one in DEPEND, and also
+ # prevent automagic fallbacks.
+ --with-libevent
+ --without-libev
+
+ $(use_enable debug)
$(use_with munge)
+ )
+
+ econf "${myeconfargs[@]}"
}
src_install() {