summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-cluster/legion/legion-21.09.0-r1.ebuild')
-rw-r--r--sys-cluster/legion/legion-21.09.0-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/sys-cluster/legion/legion-21.09.0-r1.ebuild b/sys-cluster/legion/legion-21.09.0-r1.ebuild
new file mode 100644
index 000000000000..55c79a8cda25
--- /dev/null
+++ b/sys-cluster/legion/legion-21.09.0-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="A data-centric parallel programming system"
+HOMEPAGE="https://legion.stanford.edu/"
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://StanfordLegion/${PN}.git https://github.com/StanfordLegion/${PN}.git"
+else
+ SRC_URI="https://github.com/StanfordLegion/${PN}/archive/${P}.tar.gz"
+ S="${WORKDIR}"/${PN}-${P}
+
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="examples gasnet hwloc test"
+RESTRICT="!test? ( test )"
+
+# See bug #821424 for examples/mpi
+DEPEND="examples? ( virtual/mpi[cxx] )
+ gasnet? ( >=sys-cluster/gasnet-1.26.4-r1 )
+ hwloc? ( <sys-apps/hwloc-2:= )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DLegion_USE_HWLOC=$(usex hwloc)
+ -DLegion_USE_GASNet=$(usex gasnet)
+ -DLegion_ENABLE_TESTING=$(usex test)
+ -DLegion_BUILD_EXAMPLES=$(usex examples)
+ -DLegion_BUILD_TESTS=ON
+ -DLegion_BUILD_TUTORIAL=ON
+ )
+
+ cmake_src_configure
+}