summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-auth/icmpdn')
-rw-r--r--sys-auth/icmpdn/Manifest1
-rw-r--r--sys-auth/icmpdn/files/conf.d-icmpdnd15
-rw-r--r--sys-auth/icmpdn/files/init.d-icmpdnd27
-rw-r--r--sys-auth/icmpdn/icmpdn-0.4.ebuild39
-rw-r--r--sys-auth/icmpdn/metadata.xml7
5 files changed, 89 insertions, 0 deletions
diff --git a/sys-auth/icmpdn/Manifest b/sys-auth/icmpdn/Manifest
new file mode 100644
index 000000000000..fb07119772bd
--- /dev/null
+++ b/sys-auth/icmpdn/Manifest
@@ -0,0 +1 @@
+DIST icmpdn-0.4.tar.gz 332780 RMD160 48b640f84afbcb531d16aa13b9841bc795606f82 SHA1 211163a952dd7e3196fce3b0c6a5ea0d2bd4c0bb SHA256 8d53bd2ddfeb1a013b549e7e5d4a606af50d621b6e803dcfac9d870c77af8b45
diff --git a/sys-auth/icmpdn/files/conf.d-icmpdnd b/sys-auth/icmpdn/files/conf.d-icmpdnd
new file mode 100644
index 000000000000..e6fb8e406620
--- /dev/null
+++ b/sys-auth/icmpdn/files/conf.d-icmpdnd
@@ -0,0 +1,15 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# Set the TTL (Time-to-Live) value in responses to TTL seconds rather
+# than the default of 3600 seconds
+#TTL=3600
+
+# Set the domain name in responses to domainname, rather than the
+# default as described above. This option is useful in case the system
+# is not configured to set up its own hostname.
+#DOMAINNAME=mydomainname.com
+
+# Other options
+#ICMPDND_OPTS=""
diff --git a/sys-auth/icmpdn/files/init.d-icmpdnd b/sys-auth/icmpdn/files/init.d-icmpdnd
new file mode 100644
index 000000000000..9b5e59c22c71
--- /dev/null
+++ b/sys-auth/icmpdn/files/init.d-icmpdnd
@@ -0,0 +1,27 @@
+#!/sbin/runscript
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+BINARY="/usr/sbin/icmpdnd"
+
+[ -n "${TTL}" ] && ICMPDND_OPTS="${ICMPDND_OPTS} -t ${TTL}"
+[ -n "${DOMAINNAME}" ] && ICMPDND_OPTS="${ICMPDND_OPTS} -d ${DOMAINNAME}"
+
+depend() {
+ need net
+ after ypbind
+}
+
+start() {
+ ebegin "Starting icmpdnd"
+ start-stop-daemon --start --quiet --exec ${BINARY} -- ${ICMPDND_OPTS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping icmpdnd"
+ start-stop-daemon --stop --quiet --exec ${BINARY}
+ eend $?
+}
+
diff --git a/sys-auth/icmpdn/icmpdn-0.4.ebuild b/sys-auth/icmpdn/icmpdn-0.4.ebuild
new file mode 100644
index 000000000000..21119d148504
--- /dev/null
+++ b/sys-auth/icmpdn/icmpdn-0.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils flag-o-matic multilib
+
+DESCRIPTION="ICMP Domain Name utilities & NSS backend"
+HOMEPAGE="http://www.dolda2000.com/~fredrik/icmp-dn/"
+SRC_URI="${HOMEPAGE}${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+src_compile() {
+ append-cppflags -D_GNU_SOURCE #241318
+ econf \
+ --sysconfdir=/etc \
+ --libdir=/$(get_libdir) \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+ newinitd "${FILESDIR}"/init.d-icmpdnd icmpdnd
+ newconfd "${FILESDIR}"/conf.d-icmpdnd icmpdnd
+ dodoc AUTHORS ChangeLog README
+ # must always run as root
+ fperms 4711 /usr/bin/idnlookup
+ # useless as nothing should link against this lib
+ rm "${D}"/lib*/*.{la,so}
+}
+
+pkg_postinst() {
+ einfo "To use the ICMP nameswitch module, add 'icmp'"
+ einfo "to the 'hosts' line in your /etc/nsswitch.conf"
+}
diff --git a/sys-auth/icmpdn/metadata.xml b/sys-auth/icmpdn/metadata.xml
new file mode 100644
index 000000000000..c6d862855eb5
--- /dev/null
+++ b/sys-auth/icmpdn/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>robbat2@gentoo.org</email>
+</maintainer>
+</pkgmetadata>