summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/petsc')
-rw-r--r--sci-mathematics/petsc/petsc-3.16.0-r1.ebuild6
-rw-r--r--sci-mathematics/petsc/petsc-3.17.1-r1.ebuild6
-rw-r--r--sci-mathematics/petsc/petsc-3.18.2.ebuild6
-rw-r--r--sci-mathematics/petsc/petsc-3.19.1.ebuild6
-rw-r--r--sci-mathematics/petsc/petsc-3.19.2.ebuild6
-rw-r--r--sci-mathematics/petsc/petsc-3.19.4.ebuild6
6 files changed, 18 insertions, 18 deletions
diff --git a/sci-mathematics/petsc/petsc-3.16.0-r1.ebuild b/sci-mathematics/petsc/petsc-3.16.0-r1.ebuild
index 6fb38f147f14..743b36c54912 100644
--- a/sci-mathematics/petsc/petsc-3.16.0-r1.ebuild
+++ b/sci-mathematics/petsc/petsc-3.16.0-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{9..10} )
+PYTHON_COMPAT=( python3_10 )
inherit flag-o-matic fortran-2 python-any-r1 toolchain-funcs
@@ -50,7 +50,7 @@ RDEPEND="
DEPEND="${RDEPEND}
${PYTHON_DEPS}
virtual/pkgconfig
- dev-util/cmake
+ dev-build/cmake
sys-apps/which
"
diff --git a/sci-mathematics/petsc/petsc-3.17.1-r1.ebuild b/sci-mathematics/petsc/petsc-3.17.1-r1.ebuild
index c38d34317074..5caa2d8578da 100644
--- a/sci-mathematics/petsc/petsc-3.17.1-r1.ebuild
+++ b/sci-mathematics/petsc/petsc-3.17.1-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{9..10} pypy3 )
+PYTHON_COMPAT=( python3_10 pypy3 )
inherit flag-o-matic fortran-2 python-any-r1 toolchain-funcs
@@ -41,7 +41,7 @@ DEPEND="
${PYTHON_DEPS}
"
BDEPEND="
- dev-util/cmake
+ dev-build/cmake
sys-apps/which
virtual/pkgconfig
"
diff --git a/sci-mathematics/petsc/petsc-3.18.2.ebuild b/sci-mathematics/petsc/petsc-3.18.2.ebuild
index f57281175844..27e8a71e87ea 100644
--- a/sci-mathematics/petsc/petsc-3.18.2.ebuild
+++ b/sci-mathematics/petsc/petsc-3.18.2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{9..11} pypy3 )
+PYTHON_COMPAT=( python3_{10..11} pypy3 )
inherit flag-o-matic fortran-2 python-any-r1 toolchain-funcs
@@ -41,7 +41,7 @@ DEPEND="
${PYTHON_DEPS}
"
BDEPEND="
- dev-util/cmake
+ dev-build/cmake
sys-apps/which
virtual/pkgconfig
"
diff --git a/sci-mathematics/petsc/petsc-3.19.1.ebuild b/sci-mathematics/petsc/petsc-3.19.1.ebuild
index f57281175844..27e8a71e87ea 100644
--- a/sci-mathematics/petsc/petsc-3.19.1.ebuild
+++ b/sci-mathematics/petsc/petsc-3.19.1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{9..11} pypy3 )
+PYTHON_COMPAT=( python3_{10..11} pypy3 )
inherit flag-o-matic fortran-2 python-any-r1 toolchain-funcs
@@ -41,7 +41,7 @@ DEPEND="
${PYTHON_DEPS}
"
BDEPEND="
- dev-util/cmake
+ dev-build/cmake
sys-apps/which
virtual/pkgconfig
"
diff --git a/sci-mathematics/petsc/petsc-3.19.2.ebuild b/sci-mathematics/petsc/petsc-3.19.2.ebuild
index f57281175844..27e8a71e87ea 100644
--- a/sci-mathematics/petsc/petsc-3.19.2.ebuild
+++ b/sci-mathematics/petsc/petsc-3.19.2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{9..11} pypy3 )
+PYTHON_COMPAT=( python3_{10..11} pypy3 )
inherit flag-o-matic fortran-2 python-any-r1 toolchain-funcs
@@ -41,7 +41,7 @@ DEPEND="
${PYTHON_DEPS}
"
BDEPEND="
- dev-util/cmake
+ dev-build/cmake
sys-apps/which
virtual/pkgconfig
"
diff --git a/sci-mathematics/petsc/petsc-3.19.4.ebuild b/sci-mathematics/petsc/petsc-3.19.4.ebuild
index f57281175844..27e8a71e87ea 100644
--- a/sci-mathematics/petsc/petsc-3.19.4.ebuild
+++ b/sci-mathematics/petsc/petsc-3.19.4.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{9..11} pypy3 )
+PYTHON_COMPAT=( python3_{10..11} pypy3 )
inherit flag-o-matic fortran-2 python-any-r1 toolchain-funcs
@@ -41,7 +41,7 @@ DEPEND="
${PYTHON_DEPS}
"
BDEPEND="
- dev-util/cmake
+ dev-build/cmake
sys-apps/which
virtual/pkgconfig
"