summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/ondselsolver/files/ondselsolver-1.0.1_p20241024-system-gtest.patch')
-rw-r--r--sci-libs/ondselsolver/files/ondselsolver-1.0.1_p20241024-system-gtest.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/sci-libs/ondselsolver/files/ondselsolver-1.0.1_p20241024-system-gtest.patch b/sci-libs/ondselsolver/files/ondselsolver-1.0.1_p20241024-system-gtest.patch
new file mode 100644
index 000000000000..16258763011a
--- /dev/null
+++ b/sci-libs/ondselsolver/files/ondselsolver-1.0.1_p20241024-system-gtest.patch
@@ -0,0 +1,26 @@
+--- a/tests/CMakeLists.txt
++++ b/tests/CMakeLists.txt
+@@ -1,11 +1,4 @@
+-include(FetchContent)
+-FetchContent_Declare(
+- googletest
+- URL https://github.com/google/googletest/archive/03597a01ee50ed33e9dfd640b249b4be3799d395.zip
+-)
+-# For Windows: Prevent overriding the parent project's compiler/linker settings
+-set(gtest_force_shared_crt ON CACHE BOOL "" FORCE)
+-FetchContent_MakeAvailable(googletest)
++find_package(GTest QUIET)
+
+ if(MSVC)
+ add_compile_options(/wd4251)
+@@ -54,8 +47,8 @@
+ ${CMAKE_CURRENT_SOURCE_DIR}/test.cpp
+ )
+ target_link_libraries(test_run
+- gtest_main
+- gmock_main
++ GTest::gtest
++ GTest::gmock_main
+ ${Google_Tests_LIBS}
+ OndselSolver
+ )