summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/socket++')
-rw-r--r--net-libs/socket++/Manifest2
-rw-r--r--net-libs/socket++/files/socket++-1.12.12-gcc47.patch20
-rw-r--r--net-libs/socket++/files/socket++.pc11
-rw-r--r--net-libs/socket++/metadata.xml6
-rw-r--r--net-libs/socket++/socket++-1.12.12-r2.ebuild41
-rw-r--r--net-libs/socket++/socket++-1.12.13.ebuild41
6 files changed, 121 insertions, 0 deletions
diff --git a/net-libs/socket++/Manifest b/net-libs/socket++/Manifest
new file mode 100644
index 000000000000..e524a0f17836
--- /dev/null
+++ b/net-libs/socket++/Manifest
@@ -0,0 +1,2 @@
+DIST socket++-1.12.12.tar.gz 64373 SHA256 e779cfe92ee2fd73841f91b0192350e5b796bedc11f1e69c4f1d792851cdc28d SHA512 3cc45721da058114586553e9d758fbbba5a135cd09289b5362dd573a2070aa3330d7b7d08b42a39fbb874314aa7e6f05bf571d36628ef63ba95ff6e1e9b356b6 WHIRLPOOL 5e2f2bfc6ef4433db3ab2e26e3c94eeb301c85283602a60b8eeef6379c609dbbd2d649810ca15f822cc4d8774b0d7a59ce04c15692f004d7420ad6bcdafaf67d
+DIST socket++-1.12.13.tar.gz 64263 SHA256 755cdcac06d40fcca2b221f840e05f89a86298bc3bfc518b51a57b42f0512b19 SHA512 080f4cc71c4edcf56d81b8574ff357bc24f7a740a6a3c7e92a2dfd7d8910193e919fc270fcc8e96ea769518854b6e45ec79b949ecaef69f30edf821ae4bd625b WHIRLPOOL c08fd6641089107933f8c91a4b483881a7798aecf88702f17bd83f880698abcbb20f2951c39c4a0e49e495bbf9092ed614cb2aca1c99f86951b4598b6bdfe3d1
diff --git a/net-libs/socket++/files/socket++-1.12.12-gcc47.patch b/net-libs/socket++/files/socket++-1.12.12-gcc47.patch
new file mode 100644
index 000000000000..62a62b090041
--- /dev/null
+++ b/net-libs/socket++/files/socket++-1.12.12-gcc47.patch
@@ -0,0 +1,20 @@
+--- test/thostnames.C~ 2004-06-29 08:47:52.000000000 +0200
++++ test/thostnames.C 2013-09-07 10:30:24.159157101 +0200
+@@ -23,7 +23,7 @@
+ {
+ public:
+ test () : iosockinet (sockbuf::sock_stream) {
+- cout << "Constructor rdbuf: " << (unsigned int) rdbuf() << endl;
++ cout << "Constructor rdbuf: " << (size_t) rdbuf() << endl;
+ }
+ };
+
+@@ -39,7 +39,7 @@
+ }
+
+ sio.rdbuf()->setname ("Testsocket");
+- cout << "rdbuf: " << (unsigned int) sio.rdbuf() << "\n";
++ cout << "rdbuf: " << (size_t) sio.rdbuf() << "\n";
+ cout << "socketname: " << sio.rdbuf()->getname() << endl;
+
+ try {
diff --git a/net-libs/socket++/files/socket++.pc b/net-libs/socket++/files/socket++.pc
new file mode 100644
index 000000000000..4faaa9c62149
--- /dev/null
+++ b/net-libs/socket++/files/socket++.pc
@@ -0,0 +1,11 @@
+prefix=/usr
+exec_prefix=/usr/bin
+libdir=/usr/lib
+includedir=/usr/include
+
+Name: socket++
+Version: PV
+Description: A C++ Socket Library
+Requires:
+Libs: -L/usr/lib -lsocket++
+Cflags: -I/usr/include
diff --git a/net-libs/socket++/metadata.xml b/net-libs/socket++/metadata.xml
new file mode 100644
index 000000000000..54cb0feb0740
--- /dev/null
+++ b/net-libs/socket++/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>cpp</herd>
+ <longdescription>Socket++ library defines a family of C++ classes that can be used more effectively than directly calling the underlying low-level system functions.</longdescription>
+</pkgmetadata>
diff --git a/net-libs/socket++/socket++-1.12.12-r2.ebuild b/net-libs/socket++/socket++-1.12.12-r2.ebuild
new file mode 100644
index 000000000000..c223ff7933c1
--- /dev/null
+++ b/net-libs/socket++/socket++-1.12.12-r2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=1
+inherit autotools-utils
+
+DESCRIPTION="C++ Socket Library"
+HOMEPAGE="http://www.linuxhacker.at/socketxx/"
+SRC_URI="http://www.linuxhacker.at/linux/downloads/src/${P}.tar.gz"
+
+LICENSE="freedist GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~mips x86"
+
+IUSE="debug static-libs"
+
+RESTRICT="bindist"
+
+DEPEND="sys-apps/texinfo"
+RDEPEND=""
+
+DOCS=( AUTHORS ChangeLog NEWS README README2 README3 THANKS )
+
+PATCHES=( "${FILESDIR}/${P}-gcc47.patch" )
+
+src_prepare() {
+ # bug #514246
+ sed -i -e 's/@subsection t/@section t/g' doc/socket++.texi || die
+
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable debug)
+ )
+ autotools-utils_src_configure
+}
diff --git a/net-libs/socket++/socket++-1.12.13.ebuild b/net-libs/socket++/socket++-1.12.13.ebuild
new file mode 100644
index 000000000000..7fe0dcc5953e
--- /dev/null
+++ b/net-libs/socket++/socket++-1.12.13.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=1
+inherit autotools-utils
+
+DESCRIPTION="C++ Socket Library"
+HOMEPAGE="http://www.linuxhacker.at/socketxx/"
+SRC_URI="http://src.linuxhacker.at/socket++/${P}.tar.gz"
+
+LICENSE="freedist GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~mips ~x86"
+
+IUSE="debug static-libs"
+
+RESTRICT="bindist"
+
+DEPEND="sys-apps/texinfo"
+RDEPEND=""
+
+DOCS=( AUTHORS ChangeLog NEWS README README2 README3 THANKS )
+
+PATCHES=( "${FILESDIR}/${PN}-1.12.12-gcc47.patch" )
+
+src_prepare() {
+ # bug #514246
+ sed -i -e 's/@subsection t/@section t/g' doc/socket++.texi || die
+
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable debug)
+ )
+ autotools-utils_src_configure
+}