summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/rb_libtorrent/rb_libtorrent-0.16.17.ebuild')
-rw-r--r--net-libs/rb_libtorrent/rb_libtorrent-0.16.17.ebuild78
1 files changed, 78 insertions, 0 deletions
diff --git a/net-libs/rb_libtorrent/rb_libtorrent-0.16.17.ebuild b/net-libs/rb_libtorrent/rb_libtorrent-0.16.17.ebuild
new file mode 100644
index 000000000000..21530dc43907
--- /dev/null
+++ b/net-libs/rb_libtorrent/rb_libtorrent-0.16.17.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+PYTHON_DEPEND="python? 2:2.7"
+PYTHON_USE_WITH="threads"
+PYTHON_USE_WITH_OPT="python"
+
+inherit multilib python versionator
+
+MY_P=${P/rb_/}
+MY_P=${MY_P/torrent/torrent-rasterbar}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="C++ BitTorrent implementation focusing on efficiency and scalability"
+HOMEPAGE="http://www.rasterbar.com/products/libtorrent/"
+SRC_URI="mirror://sourceforge/libtorrent/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 arm ppc ppc64 sparc x86 ~x86-fbsd"
+IUSE="debug doc examples python ssl static-libs test"
+RESTRICT="test"
+
+DEPEND=">=dev-libs/boost-1.48[python?,threads(+)]
+ >=sys-devel/libtool-2.2
+ sys-libs/zlib
+ examples? ( !net-p2p/mldonkey )
+ ssl? ( dev-libs/openssl )"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ if use python; then
+ python_set_active_version 2
+ python_pkg_setup
+ fi
+}
+
+src_prepare() {
+ use python && python_convert_shebangs -r 2 .
+}
+
+src_configure() {
+ local myconf
+
+ # bug 441842
+ myconf="--disable-silent-rules"
+
+ # use multi-threading versions of boost libs
+ if has_version '>=dev-libs/boost-1.52.0-r1'; then
+ myconf+=" --with-boost-python=boost_python-${PYTHON_ABI}"
+ else
+ myconf+=" --with-boost-system=boost_system-mt \
+ --with-boost-python=boost_python-${PYTHON_ABI}-mt"
+ fi
+
+ local LOGGING
+ use debug && myconf+=" --enable-logging=verbose"
+
+ econf $(use_enable debug) \
+ $(use_enable test tests) \
+ $(use_enable examples) \
+ $(use_enable python python-binding) \
+ $(use_enable ssl encryption) \
+ $(use_enable static-libs static) \
+ --with-boost-libdir=/usr/$(get_libdir) \
+ ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ use static-libs || find "${D}" -name '*.la' -exec rm -f {} +
+ dodoc ChangeLog AUTHORS NEWS README
+ if use doc; then
+ dohtml docs/*
+ fi
+}