summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/openslp/openslp-2.0.0.ebuild')
-rw-r--r--net-libs/openslp/openslp-2.0.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/net-libs/openslp/openslp-2.0.0.ebuild b/net-libs/openslp/openslp-2.0.0.ebuild
new file mode 100644
index 000000000000..e7b3ed9ea0bc
--- /dev/null
+++ b/net-libs/openslp/openslp-2.0.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils autotools systemd
+
+DESCRIPTION="An open-source implementation of Service Location Protocol"
+HOMEPAGE="http://www.openslp.org/"
+SRC_URI="mirror://sourceforge/openslp/${P}.tar.gz"
+
+LICENSE="BSD GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+RESTRICT="test"
+
+DEPEND="dev-libs/openssl"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.0.0-cflags.patch
+ eautoreconf
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS FAQ ChangeLog NEWS README* THANKS
+ rm -rfv "${D}"/usr/doc
+ dohtml -r .
+ newinitd "${FILESDIR}"/slpd-init slpd
+ systemd_dounit "${FILESDIR}"/slpd.service
+}