summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/libprotoident')
-rw-r--r--net-libs/libprotoident/Manifest1
-rw-r--r--net-libs/libprotoident/libprotoident-2.0.7.ebuild28
-rw-r--r--net-libs/libprotoident/metadata.xml8
3 files changed, 37 insertions, 0 deletions
diff --git a/net-libs/libprotoident/Manifest b/net-libs/libprotoident/Manifest
new file mode 100644
index 000000000000..d7764bcb65f9
--- /dev/null
+++ b/net-libs/libprotoident/Manifest
@@ -0,0 +1 @@
+DIST libprotoident-2.0.7.tar.gz 483119 SHA256 5063497274e546b01b0606c8906a292cbe1e2ba8d6f3b6cd25de16a91fef635e SHA512 0491a2c67f1cd43dc82d68f8d6d3d6c423a7ba6ce07141107b9f50c08b858974c504dcf563501b3f33c29e799baa88871444f12ebf5f6c70adc73c08824dced8 WHIRLPOOL 37c9eecd5f3ba81d02d849aebeab05b21e26c0e0e58718a55841c500c9c33faf3cecac5d564a619a2aaf7d5c4e703297997f8e45d575d846ca9c1c6a34e8f6d6
diff --git a/net-libs/libprotoident/libprotoident-2.0.7.ebuild b/net-libs/libprotoident/libprotoident-2.0.7.ebuild
new file mode 100644
index 000000000000..dbb4c22a87c3
--- /dev/null
+++ b/net-libs/libprotoident/libprotoident-2.0.7.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools-utils
+
+DESCRIPTION="A library that performs application layer protocol identification for flows"
+HOMEPAGE="http://research.wand.net.nz/software/libprotoident.php"
+SRC_URI="http://research.wand.net.nz/software/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/2"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs +tools"
+
+DEPEND=">=net-libs/libtrace-3.0.7
+ tools? ( net-libs/libflowmanager )"
+RDEPEND="${DEPEND}"
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+src_configure() {
+ local myeconfargs=(
+ $(use_with tools)
+ )
+ autotools-utils_src_configure
+}
diff --git a/net-libs/libprotoident/metadata.xml b/net-libs/libprotoident/metadata.xml
new file mode 100644
index 000000000000..2281ff091ad3
--- /dev/null
+++ b/net-libs/libprotoident/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>netmon</herd>
+ <use>
+ <flag name="tools">Build and install command-line tools</flag>
+ </use>
+</pkgmetadata>