summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/libeXosip/libeXosip-3.5.0.ebuild')
-rw-r--r--net-libs/libeXosip/libeXosip-3.5.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/net-libs/libeXosip/libeXosip-3.5.0.ebuild b/net-libs/libeXosip/libeXosip-3.5.0.ebuild
new file mode 100644
index 000000000000..9b36577cc24f
--- /dev/null
+++ b/net-libs/libeXosip/libeXosip-3.5.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit eutils
+
+MY_PV=${PV%.?}-${PV##*.}
+MY_PV=${PV}
+MY_P=${PN}2-${MY_PV}
+DESCRIPTION="library that hides the complexity of using the SIP protocol for multimedia session establishement"
+HOMEPAGE="http://savannah.nongnu.org/projects/exosip/"
+SRC_URI="http://download.savannah.nongnu.org/releases/exosip/${MY_P}.tar.gz"
+
+KEYWORDS="amd64 ppc x86 ~ppc-macos ~x86-macos"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE="+srv ssl"
+
+DEPEND=">=net-libs/libosip-3.2.0
+ <net-libs/libosip-4
+ ssl? ( dev-libs/openssl )"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+ econf \
+ --enable-mt \
+ $(use_enable ssl openssl) \
+ $(use_enable srv srvrec)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README
+}