summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/tcpdump/tcpdump-4.99.0.ebuild')
-rw-r--r--net-analyzer/tcpdump/tcpdump-4.99.0.ebuild19
1 files changed, 14 insertions, 5 deletions
diff --git a/net-analyzer/tcpdump/tcpdump-4.99.0.ebuild b/net-analyzer/tcpdump/tcpdump-4.99.0.ebuild
index 03742866ec3d..98642f217869 100644
--- a/net-analyzer/tcpdump/tcpdump-4.99.0.ebuild
+++ b/net-analyzer/tcpdump/tcpdump-4.99.0.ebuild
@@ -7,18 +7,26 @@ inherit autotools
DESCRIPTION="A tool for network monitoring and data acquisition"
HOMEPAGE="https://www.tcpdump.org/ https://github.com/the-tcpdump-group/tcpdump"
-SRC_URI="https://github.com/the-tcpdump-group/${PN}/archive/${P/_}.tar.gz"
-S="${WORKDIR}/${PN}-${P/_}"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/the-tcpdump-group/tcpdump"
+else
+ SRC_URI="https://github.com/the-tcpdump-group/${PN}/archive/${P/_}.tar.gz"
+ S="${WORKDIR}/${PN}-${P/_}"
+
+ KEYWORDS="~alpha amd64 arm ~arm64 ~hppa ~ia64 ~mips ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux"
+fi
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~alpha amd64 arm ~arm64 ~hppa ~ia64 ~mips ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux"
IUSE="+drop-root libressl +smi +ssl +samba suid test"
+REQUIRED_USE="test? ( samba )"
+
# Assorted failures: bug #768498
RESTRICT="test"
-REQUIRED_USE="test? ( samba )"
-BDEPEND="drop-root? ( virtual/pkgconfig )"
RDEPEND="
net-libs/libpcap
drop-root? (
@@ -43,6 +51,7 @@ DEPEND="
dev-lang/perl
)
"
+BDEPEND="drop-root? ( virtual/pkgconfig )"
PATCHES=(
"${FILESDIR}"/${PN}-9999-libdir.patch