summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/rrdcollect/rrdcollect-0.2.9.ebuild')
-rw-r--r--net-analyzer/rrdcollect/rrdcollect-0.2.9.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/net-analyzer/rrdcollect/rrdcollect-0.2.9.ebuild b/net-analyzer/rrdcollect/rrdcollect-0.2.9.ebuild
new file mode 100644
index 000000000000..f3c04ae5fedb
--- /dev/null
+++ b/net-analyzer/rrdcollect/rrdcollect-0.2.9.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Read system statistical data and feed it to RRDtool"
+HOMEPAGE="http://rrdcollect.sourceforge.net/"
+SRC_URI="mirror://sourceforge/rrdcollect/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="exec librrd pcre"
+
+DEPEND="
+ librrd? ( net-analyzer/rrdtool )
+ pcre? ( dev-libs/libpcre )
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-include.patch
+}
+
+src_configure() {
+ econf \
+ $(use_enable exec) \
+ $(use_with librrd) \
+ $(use_with pcre libpcre)
+}
+
+DOCS=( AUTHORS ChangeLog NEWS TODO )
+
+src_install() {
+ default
+ docinto examples
+ dodoc doc/examples/*
+}