summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/chaosreader')
-rw-r--r--net-analyzer/chaosreader/Manifest1
-rw-r--r--net-analyzer/chaosreader/chaosreader-0.94-r1.ebuild32
-rw-r--r--net-analyzer/chaosreader/chaosreader-0.94.ebuild25
-rw-r--r--net-analyzer/chaosreader/files/chaosreader-0.94-chunkcheck.patch27
-rw-r--r--net-analyzer/chaosreader/files/chaosreader-0.94-darwin.patch11
-rw-r--r--net-analyzer/chaosreader/files/chaosreader-0.94-divisionbyzero.patch18
-rw-r--r--net-analyzer/chaosreader/files/chaosreader-0.94-oldmultiline.patch15
-rw-r--r--net-analyzer/chaosreader/files/chaosreader-0.94-zombies.patch11
-rw-r--r--net-analyzer/chaosreader/metadata.xml8
9 files changed, 148 insertions, 0 deletions
diff --git a/net-analyzer/chaosreader/Manifest b/net-analyzer/chaosreader/Manifest
new file mode 100644
index 000000000000..2f1c63f3dfb4
--- /dev/null
+++ b/net-analyzer/chaosreader/Manifest
@@ -0,0 +1 @@
+DIST chaosreader-0.94.bz2 41039 SHA256 523f2107502dda9a1a9c73d8bc14605046f7352ada442bfcafec39a81b41f35b
diff --git a/net-analyzer/chaosreader/chaosreader-0.94-r1.ebuild b/net-analyzer/chaosreader/chaosreader-0.94-r1.ebuild
new file mode 100644
index 000000000000..121fb9bc05cc
--- /dev/null
+++ b/net-analyzer/chaosreader/chaosreader-0.94-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils
+
+DESCRIPTION="A tool to trace TCP/UDP/... sessions and fetch application data from snoop or tcpdump logs"
+HOMEPAGE="http://chaosreader.sourceforge.net"
+SRC_URI="http://dev.gentoo.org/~spock/portage/distfiles/${P}.bz2"
+SLOT="0"
+
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~x86-macos"
+LICENSE="GPL-2"
+
+IUSE=""
+
+DEPEND=">=dev-lang/perl-5.8.0"
+S=${WORKDIR}
+
+src_prepare() {
+ epatch "${FILESDIR}"/chaosreader-0.94-zombies.patch
+ epatch "${FILESDIR}"/chaosreader-0.94-chunkcheck.patch
+ epatch "${FILESDIR}"/chaosreader-0.94-darwin.patch
+ epatch "${FILESDIR}"/chaosreader-0.94-divisionbyzero.patch
+ epatch "${FILESDIR}"/chaosreader-0.94-oldmultiline.patch
+}
+
+src_install() {
+ newbin ${P} chaosreader
+}
diff --git a/net-analyzer/chaosreader/chaosreader-0.94.ebuild b/net-analyzer/chaosreader/chaosreader-0.94.ebuild
new file mode 100644
index 000000000000..922050b801e5
--- /dev/null
+++ b/net-analyzer/chaosreader/chaosreader-0.94.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="A tool to trace TCP/UDP/... sessions and fetch application data from snoop or tcpdump logs"
+HOMEPAGE="http://users.tpg.com.au/bdgcvb/chaosreader.html"
+SRC_URI="http://dev.gentoo.org/~spock/portage/distfiles/${P}.bz2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc x86 ~amd64-linux ~x86-linux ~x86-macos"
+LICENSE="GPL-2"
+IUSE=""
+DEPEND=">=dev-lang/perl-5.8.0"
+S=${WORKDIR}
+
+src_prepare() {
+ epatch "${FILESDIR}"/chaosreader-0.94-zombies.patch
+}
+
+src_install() {
+ newbin ${P} chaosreader || die
+}
diff --git a/net-analyzer/chaosreader/files/chaosreader-0.94-chunkcheck.patch b/net-analyzer/chaosreader/files/chaosreader-0.94-chunkcheck.patch
new file mode 100644
index 000000000000..547af04db5b7
--- /dev/null
+++ b/net-analyzer/chaosreader/files/chaosreader-0.94-chunkcheck.patch
@@ -0,0 +1,27 @@
+--- chaosreader 2011-11-10 19:17:50.000000000 +0100
++++ chaosreader-0.94 2012-03-09 18:15:21.096105305 +0100
+@@ -5350,6 +5353,24 @@
+ next if length($http_data) < 8;
+ $partnum++;
+ $parttext = sprintf("%02d",$partnum);
++
++ ## from http://sourceforge.net/tracker/?func=detail&aid=2019799&group_id=107384&atid=647491
++ ### Chunk Check
++ if ( $http_header =~ /Transfer-Encoding: chunked/ ) {
++ my $new_http_data="";
++ my $chunksize=-1;
++ my $pos=0;
++ until ($chunksize==0) {
++ my $eolpos=index($http_data,"\r\n",$pos);
++ $chunksize=hex(substr($http_data,$pos,$eolpos - $pos));
++ $pos=($eolpos+2);
++ if ($chunksize > 0) {
++ $new_http_data.=substr($http_data,$pos,$chunksize);
++ }
++ $pos+=($chunksize+2);
++ }
++ $http_data=$new_http_data;
++ }
+
+ ### Part - Checks
+ $http_type = &File_Type($http_data);
diff --git a/net-analyzer/chaosreader/files/chaosreader-0.94-darwin.patch b/net-analyzer/chaosreader/files/chaosreader-0.94-darwin.patch
new file mode 100644
index 000000000000..2eaca80909ae
--- /dev/null
+++ b/net-analyzer/chaosreader/files/chaosreader-0.94-darwin.patch
@@ -0,0 +1,11 @@
+--- chaosreader 2011-11-10 19:17:50.000000000 +0100
++++ chaosreader-0.94 2012-03-09 18:15:21.096105305 +0100
+@@ -6233,6 +6254,8 @@
+ $command = "tcpdump -s9999 -w";
+ } elsif ($^O eq "solaris") {
+ $command = "snoop -o";
++ } elsif ($^O eq "darwin") {
++ $command = "tcpdump -i en1 -s9999 -w";
+ } else {
+ die "ERROR54: Can't find the sniffer command for \"$^O\".\n" .
+ "\t Please use log mode instead.\n";
diff --git a/net-analyzer/chaosreader/files/chaosreader-0.94-divisionbyzero.patch b/net-analyzer/chaosreader/files/chaosreader-0.94-divisionbyzero.patch
new file mode 100644
index 000000000000..7f3ec2804dd4
--- /dev/null
+++ b/net-analyzer/chaosreader/files/chaosreader-0.94-divisionbyzero.patch
@@ -0,0 +1,18 @@
+--- chaosreader 2011-11-10 19:17:50.000000000 +0100
++++ chaosreader-0.94 2012-03-09 18:15:21.096105305 +0100
+@@ -4028,7 +4024,14 @@
+ ### This causes the replay program to pause
+ print REPLAY "ms($timediff1);\n";
+ }
+- $speed = sprintf("%.2f",$bytes / (1024 * $duration));
++ # avoid division by zero
++ # from http://sourceforge.net/tracker/?func=detail&aid=2210488&group_id=107384&atid=647489
++ if ( $duration > 0 ) {
++ $speed = sprintf("%.2f",$bytes / (1024 * $duration));
++ }
++ else {
++ $speed = "unknown";
++ }
+ print REPLAY "print \"\n\n" .
+ "Summary: $duration2 seconds, $bytes bytes, $speed Kb/sec\\n\";";
+ close REPLAY;
diff --git a/net-analyzer/chaosreader/files/chaosreader-0.94-oldmultiline.patch b/net-analyzer/chaosreader/files/chaosreader-0.94-oldmultiline.patch
new file mode 100644
index 000000000000..1fada077058e
--- /dev/null
+++ b/net-analyzer/chaosreader/files/chaosreader-0.94-oldmultiline.patch
@@ -0,0 +1,15 @@
+--- chaosreader 2012-01-18 21:47:02.000000000 +0100
++++ chaosreader-0.94 2012-03-13 12:10:44.740136742 +0100
+@@ -259,12 +259,6 @@
+ $| = 1; # flush output
+
+ #
+-# The following is needed for old perl5 multiline matching. New perl5 uses
+-# a "/s" on the RE (which is used in this program as well).
+-#
+-$* = 1; # old perl5
+-
+-#
+ # These ports have been selected to be saved as coloured 2-way HTML files
+ #
+ @Save_As_HTML_TCP_Ports = (21,23,25,79,80,109,110,119,143,513,514,1080,
diff --git a/net-analyzer/chaosreader/files/chaosreader-0.94-zombies.patch b/net-analyzer/chaosreader/files/chaosreader-0.94-zombies.patch
new file mode 100644
index 000000000000..8f7dd04e50ed
--- /dev/null
+++ b/net-analyzer/chaosreader/files/chaosreader-0.94-zombies.patch
@@ -0,0 +1,11 @@
+--- chaosreader-orig 2006-12-24 15:12:23.000000000 +0100
++++ chaosreader-0.94 2006-12-24 15:11:56.000000000 +0100
+@@ -396,6 +395,8 @@ if ($Arg{normal}) {
+
+ elsif ($Arg{standalone}) {
+
++ $SIG{CHLD} = "IGNORE";
++
+ ############################################################
+ # --- STANDALONE - Create Packet Logs and Process them ---
+ #
diff --git a/net-analyzer/chaosreader/metadata.xml b/net-analyzer/chaosreader/metadata.xml
new file mode 100644
index 000000000000..49bbe83e76c3
--- /dev/null
+++ b/net-analyzer/chaosreader/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>proxy-maintainers</herd>
+<maintainer>
+ <email>rainbow@irh.it</email>
+</maintainer>
+</pkgmetadata>