summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/cacti-spine')
-rw-r--r--net-analyzer/cacti-spine/Manifest2
-rw-r--r--net-analyzer/cacti-spine/cacti-spine-0.8.8e.ebuild46
-rw-r--r--net-analyzer/cacti-spine/cacti-spine-0.8.8f.ebuild46
-rw-r--r--net-analyzer/cacti-spine/files/cacti-spine-0.8.8d-mysql.patch11
-rw-r--r--net-analyzer/cacti-spine/files/cacti-spine-0.8.8d-ping.patch11
-rw-r--r--net-analyzer/cacti-spine/files/cacti-spine-0.8.8d-snmp_spine_close.patch10
-rw-r--r--net-analyzer/cacti-spine/files/cacti-spine-0.8.8e-fix-ac-macro.patch11
-rw-r--r--net-analyzer/cacti-spine/files/cacti-spine-0.8.8e-net-snmp.patch19
-rw-r--r--net-analyzer/cacti-spine/files/cacti-spine-0.8.8f-fix-ac-macro.patch11
-rw-r--r--net-analyzer/cacti-spine/metadata.xml14
10 files changed, 181 insertions, 0 deletions
diff --git a/net-analyzer/cacti-spine/Manifest b/net-analyzer/cacti-spine/Manifest
new file mode 100644
index 000000000000..f93518e3d521
--- /dev/null
+++ b/net-analyzer/cacti-spine/Manifest
@@ -0,0 +1,2 @@
+DIST cacti-spine-0.8.8e.tar.gz 757042 SHA256 e014488acffd4dd3a88306c3809e93a89c8538a050c2a58a9666e4c04c004b92 SHA512 165e93d4cce3378e911aec41fcd68fb541d82d849ebf3e2e28e0ddb65027ff2eb77d488acbaa133244091cd02adb58d8f74ea5abc36abed07af9ea72bc104f40 WHIRLPOOL 59442f54fbb8956a945404f374eba848bc21b60d53dacb025132a91dc077115aa65ee30959ba81fb521beb9732c1c5944adb1c555a36ad6ea72898172404970c
+DIST cacti-spine-0.8.8f.tar.gz 757078 SHA256 d0599239187f2f5a29f82b809e6941447f18bb7b170cd42e67455633b195e3c7 SHA512 8c5e1713bb1d41227cef6047e5348ef33b90b5591976cf24390abbf1e5c68de6714f785d9517ca9aed21b42b6b8772512af176b9f62bf18d6d74d949a6359a22 WHIRLPOOL 70545057f80d5cc5940059179bc3b72eabf48ff61c5eed5b0b344e995eb1411e3a89359e8c0b6bc3850b029233597d581ece59a99c6653ac7cfd028ef2e24232
diff --git a/net-analyzer/cacti-spine/cacti-spine-0.8.8e.ebuild b/net-analyzer/cacti-spine/cacti-spine-0.8.8e.ebuild
new file mode 100644
index 000000000000..f46332095f98
--- /dev/null
+++ b/net-analyzer/cacti-spine/cacti-spine-0.8.8e.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils
+
+MY_P=${PN}-${PV/_p/-}
+
+DESCRIPTION="Spine is a fast poller for Cacti (formerly known as Cactid)"
+HOMEPAGE="http://cacti.net/spine_info.php"
+SRC_URI="http://www.cacti.net/downloads/spine/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 hppa ~ppc ~ppc64 sparc x86"
+
+DEPEND="
+ dev-libs/openssl:*
+ net-analyzer/net-snmp
+ virtual/mysql
+"
+RDEPEND="
+ ${DEPEND}
+ >net-analyzer/cacti-0.8.8
+"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-0.8.8e-fix-ac-macro.patch \
+ "${FILESDIR}"/${PN}-0.8.8e-net-snmp.patch \
+ "${FILESDIR}"/${PN}-0.8.8d-mysql.patch \
+ "${FILESDIR}"/${PN}-0.8.8d-ping.patch \
+ "${FILESDIR}"/${PN}-0.8.8d-snmp_spine_close.patch
+
+ sed -i -e 's/^bin_PROGRAMS/sbin_PROGRAMS/' Makefile.am
+ AT_M4DIR="config" eautoreconf
+}
+
+src_install() {
+ dosbin spine
+ insinto /etc/
+ insopts -m0640 -o root
+ newins spine.conf{.dist,}
+ dodoc ChangeLog README
+}
diff --git a/net-analyzer/cacti-spine/cacti-spine-0.8.8f.ebuild b/net-analyzer/cacti-spine/cacti-spine-0.8.8f.ebuild
new file mode 100644
index 000000000000..81e07ffbb733
--- /dev/null
+++ b/net-analyzer/cacti-spine/cacti-spine-0.8.8f.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils
+
+MY_P=${PN}-${PV/_p/-}
+
+DESCRIPTION="Spine is a fast poller for Cacti (formerly known as Cactid)"
+HOMEPAGE="http://cacti.net/spine_info.php"
+SRC_URI="http://www.cacti.net/downloads/spine/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+DEPEND="
+ dev-libs/openssl:*
+ net-analyzer/net-snmp
+ virtual/mysql
+"
+RDEPEND="
+ ${DEPEND}
+ >net-analyzer/cacti-0.8.8
+"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-0.8.8f-fix-ac-macro.patch \
+ "${FILESDIR}"/${PN}-0.8.8e-net-snmp.patch \
+ "${FILESDIR}"/${PN}-0.8.8d-mysql.patch \
+ "${FILESDIR}"/${PN}-0.8.8d-ping.patch \
+ "${FILESDIR}"/${PN}-0.8.8d-snmp_spine_close.patch
+
+ sed -i -e 's/^bin_PROGRAMS/sbin_PROGRAMS/' Makefile.am
+ AT_M4DIR="config" eautoreconf
+}
+
+src_install() {
+ dosbin spine
+ insinto /etc/
+ insopts -m0640 -o root
+ newins spine.conf{.dist,}
+ dodoc ChangeLog README
+}
diff --git a/net-analyzer/cacti-spine/files/cacti-spine-0.8.8d-mysql.patch b/net-analyzer/cacti-spine/files/cacti-spine-0.8.8d-mysql.patch
new file mode 100644
index 000000000000..d60653678a2c
--- /dev/null
+++ b/net-analyzer/cacti-spine/files/cacti-spine-0.8.8d-mysql.patch
@@ -0,0 +1,11 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -239,7 +239,7 @@
+ fi
+ CFLAGS="-I$MYSQL_INC_DIR $CFLAGS"
+
+-AC_CHECK_LIB(mysqlclient_r,mysql_init, LIBS="-lmysqlclient_r",
++AC_CHECK_LIB(mysqlclient_r,mysql_init, LIBS="$LIBS -lmysqlclient_r",
+ AC_MSG_ERROR([MySQL libraries not found])
+ )
+
diff --git a/net-analyzer/cacti-spine/files/cacti-spine-0.8.8d-ping.patch b/net-analyzer/cacti-spine/files/cacti-spine-0.8.8d-ping.patch
new file mode 100644
index 000000000000..0d94674ce5a3
--- /dev/null
+++ b/net-analyzer/cacti-spine/files/cacti-spine-0.8.8d-ping.patch
@@ -0,0 +1,11 @@
+--- a/ping.c
++++ b/ping.c
+@@ -813,7 +813,7 @@
+ int rv;
+
+ buf = malloc(len*sizeof(char));
+- memset(buf, 0, sizeof(buf));
++ memset(buf, 0, len*sizeof(char));
+
+ while (1) {
+ rv = gethostbyname_r(hostname, &result_buf, buf, len,
diff --git a/net-analyzer/cacti-spine/files/cacti-spine-0.8.8d-snmp_spine_close.patch b/net-analyzer/cacti-spine/files/cacti-spine-0.8.8d-snmp_spine_close.patch
new file mode 100644
index 000000000000..f39e8c6575e1
--- /dev/null
+++ b/net-analyzer/cacti-spine/files/cacti-spine-0.8.8d-snmp_spine_close.patch
@@ -0,0 +1,10 @@
+--- a/snmp.h
++++ b/snmp.h
+@@ -32,6 +32,7 @@
+ */
+
+ extern void snmp_spine_init(void);
++extern void snmp_spine_close(void);
+ extern void *snmp_host_init(int host_id, char *hostname, int snmp_version, char *snmp_community, char *snmp_username, char *snmp_password, char *snmp_auth_protocol, char *snmp_priv_passphrase, char *snmp_priv_protocol, char *snmp_context, int snmp_port, int snmp_timeout);
+ extern void snmp_host_cleanup(void *snmp_session);
+ extern char *snmp_get(host_t *current_host, char *snmp_oid);
diff --git a/net-analyzer/cacti-spine/files/cacti-spine-0.8.8e-fix-ac-macro.patch b/net-analyzer/cacti-spine/files/cacti-spine-0.8.8e-fix-ac-macro.patch
new file mode 100644
index 000000000000..5249cdf9386b
--- /dev/null
+++ b/net-analyzer/cacti-spine/files/cacti-spine-0.8.8e-fix-ac-macro.patch
@@ -0,0 +1,11 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -10,7 +10,7 @@
+ AC_LANG(C)
+
+ AM_INIT_AUTOMAKE(spine, 0.8.8e)
+-AM_CONFIG_HEADER(config/config.h)
++AC_CONFIG_HEADERS(config/config.h)
+
+ # static libraries
+ AC_ARG_WITH(static,
diff --git a/net-analyzer/cacti-spine/files/cacti-spine-0.8.8e-net-snmp.patch b/net-analyzer/cacti-spine/files/cacti-spine-0.8.8e-net-snmp.patch
new file mode 100644
index 000000000000..c96bbc9a7322
--- /dev/null
+++ b/net-analyzer/cacti-spine/files/cacti-spine-0.8.8e-net-snmp.patch
@@ -0,0 +1,19 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -254,14 +254,14 @@
+ )
+
+ AC_MSG_CHECKING([if Net-SNMP needs crypto support])
+-AC_TRY_COMPILE([#include <net-snmp-config.h>], [exit(USE_OPENSSL != 1);],
++AC_TRY_COMPILE([#include <net-snmp/net-snmp-config.h>], [exit(USE_OPENSSL != 1);],
+ [ AC_MSG_RESULT(yes)
+ SNMP_SSL=yes
+ ],
+ AC_MSG_RESULT(no)
+ )
+
+-AC_TRY_COMPILE([ #include <net-snmp-config.h>
++AC_TRY_COMPILE([ #include <net-snmp/net-snmp-config.h>
+ #include <net-snmp/utilities.h>
+ #include <net-snmp/net-snmp-includes.h>
+ #include <net-snmp/config_api.h>
diff --git a/net-analyzer/cacti-spine/files/cacti-spine-0.8.8f-fix-ac-macro.patch b/net-analyzer/cacti-spine/files/cacti-spine-0.8.8f-fix-ac-macro.patch
new file mode 100644
index 000000000000..a879d5e0bf96
--- /dev/null
+++ b/net-analyzer/cacti-spine/files/cacti-spine-0.8.8f-fix-ac-macro.patch
@@ -0,0 +1,11 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -10,7 +10,7 @@
+ AC_LANG(C)
+
+ AM_INIT_AUTOMAKE(spine, 0.8.8f)
+-AM_CONFIG_HEADER(config/config.h)
++AC_CONFIG_HEADERS(config/config.h)
+
+ # static libraries
+ AC_ARG_WITH(static,
diff --git a/net-analyzer/cacti-spine/metadata.xml b/net-analyzer/cacti-spine/metadata.xml
new file mode 100644
index 000000000000..18ad94010831
--- /dev/null
+++ b/net-analyzer/cacti-spine/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>netmon</herd>
+ <longdescription lang="en">
+ Spine (formerly known as Cactid) is a poller for Cacti that primarily
+ strives to be as fast as possible. For this reason it is written in
+ native C, makes use of POSIX threads, and is linked directly against the
+ net-snmp library for minmumal SNMP polling overhead. Spine is a
+ replacement for the default cmd.php poller so you must decide if using
+ Spine makes sense for your installation.
+ </longdescription>
+</pkgmetadata>
+