summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/matroxset/matroxset-0.4-r1.ebuild')
-rw-r--r--media-video/matroxset/matroxset-0.4-r1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/media-video/matroxset/matroxset-0.4-r1.ebuild b/media-video/matroxset/matroxset-0.4-r1.ebuild
new file mode 100644
index 000000000000..cb498e31f168
--- /dev/null
+++ b/media-video/matroxset/matroxset-0.4-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit toolchain-funcs
+
+DESCRIPTION="Matrox utility to switch output modes (activate tvout)"
+HOMEPAGE="ftp://platan.vc.cvut.cz/pub/linux/matrox-latest/"
+SRC_URI="ftp://platan.vc.cvut.cz/pub/linux/matrox-latest/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+
+RDEPEND="
+ sys-libs/ncurses:=
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+
+doecho() {
+ echo "$@"
+ "$@"
+}
+
+src_compile() {
+ doecho $(tc-getCC) -o ${PN} \
+ ${CFLAGS} ${LDFLAGS} \
+ ${PN}.c \
+ $($(tc-getPKG_CONFIG) --libs ncurses) \
+ || die "build failed"
+
+ #prepare small README
+ cat >> "${S}"/README << _EOF_
+This utility has been created by Petr Vandrovec
+
+Not much info here, but here are some pointers
+http://davedina.apestaart.org/download/doc/Matrox-TVOUT-HOWTO-0.1.txt
+http://www.netnode.de/howto/matrox-fb.html
+_EOF_
+}
+
+src_install() {
+ dobin matroxset
+
+ dodoc README
+}