summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/cpvts')
-rw-r--r--media-video/cpvts/Manifest1
-rw-r--r--media-video/cpvts/cpvts-1.2.ebuild42
-rw-r--r--media-video/cpvts/files/cpvts-1.2-dvdread.patch11
-rw-r--r--media-video/cpvts/metadata.xml8
4 files changed, 62 insertions, 0 deletions
diff --git a/media-video/cpvts/Manifest b/media-video/cpvts/Manifest
new file mode 100644
index 000000000000..00418f19107f
--- /dev/null
+++ b/media-video/cpvts/Manifest
@@ -0,0 +1 @@
+DIST cpvts-1.2.tgz 4200 RMD160 69da89f27c1281f8a5ffa6cffc4bbe810488850f SHA1 ebcfa950d4cceda13574a85ed2cfc60617ac4872 SHA256 cfaeb890e5ec6bd17423af8aed781410fcc4a1aebc4678598b109bb00573ee6b
diff --git a/media-video/cpvts/cpvts-1.2.ebuild b/media-video/cpvts/cpvts-1.2.ebuild
new file mode 100644
index 000000000000..cdbcf5e2a9be
--- /dev/null
+++ b/media-video/cpvts/cpvts-1.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils toolchain-funcs
+
+IUSE=""
+
+MY_S="${WORKDIR}/${PN}"
+
+DESCRIPTION="raw copy title sets from a DVD to your harddisc"
+SRC_URI="http://www.lallafa.de/bp/files/${P}.tgz"
+HOMEPAGE="http://www.lallafa.de/bp/cpvts.html"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="amd64 ppc x86"
+
+DEPEND="media-libs/libdvdread"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}-dvdread.patch"
+}
+
+echodo() {
+ echo "$@"
+ "$@" || die "failed"
+}
+
+src_compile () {
+ cd ${MY_S} || die
+
+ echodo $(tc-getCC) ${CFLAGS} ${LDFLAGS} -Wl,-rpath,/usr/lib -o cpvts \
+ cpvts.c -lm -ldvdread
+}
+
+src_install () {
+ dobin ${MY_S}/${PN} || die
+}
diff --git a/media-video/cpvts/files/cpvts-1.2-dvdread.patch b/media-video/cpvts/files/cpvts-1.2-dvdread.patch
new file mode 100644
index 000000000000..50bc92078b36
--- /dev/null
+++ b/media-video/cpvts/files/cpvts-1.2-dvdread.patch
@@ -0,0 +1,11 @@
+diff -Naur cpvts-orig/cpvts.c cpvts/cpvts.c
+--- cpvts-orig/cpvts.c 2006-03-31 20:47:16.000000000 -0600
++++ cpvts/cpvts.c 2006-03-31 20:47:40.000000000 -0600
+@@ -16,6 +16,7 @@
+ #include <ctype.h>
+ #include <string.h>
+ #include <math.h>
++#include <stdint.h>
+
+ /* libdvdread stuff */
+ #include <dvdread/dvd_reader.h>
diff --git a/media-video/cpvts/metadata.xml b/media-video/cpvts/metadata.xml
new file mode 100644
index 000000000000..c572c7d9b478
--- /dev/null
+++ b/media-video/cpvts/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>video</herd>
+ <maintainer>
+ <email>media-video@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>