summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/spotify/Manifest1
-rw-r--r--media-sound/spotify/spotify-1.1.5-r1.ebuild108
2 files changed, 0 insertions, 109 deletions
diff --git a/media-sound/spotify/Manifest b/media-sound/spotify/Manifest
index e51a245a509e..e803275739eb 100644
--- a/media-sound/spotify/Manifest
+++ b/media-sound/spotify/Manifest
@@ -1,3 +1,2 @@
DIST spotify-client_1.0.72.117.g6bd7cc73-35_i386.deb 95135550 BLAKE2B ad4587dd6b3c64a0398e0790203a7826e290a27542fa39ebbd6c7198d8ad1fd3fb06e8b030b64e1e61e0624ef20aafda08189266486cd073cb779ebff62ef502 SHA512 51d60f7592e5f31ea4b7e67736a85271cb48d4108459630da61c4ab67d2a470038240c1d6ff577280cb4498cf44f14d7bc7e0312f63d34265bcd1e70cd13142f
DIST spotify-client_1.1.10.546.ge08ef575-19_amd64.deb 114975574 BLAKE2B 46da17c8ebccdc889b723ac6e9f5275dddec97d35142606ece32d1edb1ed288d1c517d41027de22da77421a76f8c00ea90ddc868b74dd46ba07cff60a581b12a SHA512 f004083eee00600a51e50d7dee03846293b5ccd6966786e91055564c7963917b9aaa917de41f299a0f5b7baecea5f466fb37722b8631743ff2ca15f43851f5f4
-DIST spotify-client_1.1.5.153.gf614956d-16_amd64.deb 113728674 BLAKE2B bc7930a1935c0a05dba262abc384a699720be53e3bec83393c962761bee647a247d2ddf475a6812bdb969fc1f59e9d2c283de0da398a9b8f7ddfff8f1232fef1 SHA512 db354f161c35b5f1a2d633282fad8fccf565e0061e7d258012f28422d766630391d47d4dafe22448fb60f850bf4ccbfdf82443cf107e03727c077b2c62e524be
diff --git a/media-sound/spotify/spotify-1.1.5-r1.ebuild b/media-sound/spotify/spotify-1.1.5-r1.ebuild
deleted file mode 100644
index a681fe950c04..000000000000
--- a/media-sound/spotify/spotify-1.1.5-r1.ebuild
+++ /dev/null
@@ -1,108 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-inherit desktop pax-utils unpacker xdg
-
-DESCRIPTION="Spotify is a social music platform"
-HOMEPAGE="https://www.spotify.com/ch-de/download/previews/"
-SRC_BASE="http://repository.spotify.com/pool/non-free/s/${PN}-client/"
-BUILD_ID_AMD64="153.gf614956d-16"
-SRC_URI="${SRC_BASE}${PN}-client_${PV}.${BUILD_ID_AMD64}_amd64.deb"
-LICENSE="Spotify"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="libnotify libressl systray pax_kernel"
-RESTRICT="mirror strip"
-
-BDEPEND=">=dev-util/patchelf-0.10"
-# zenity needed for filepicker
-RDEPEND="
- dev-libs/nss
- dev-python/dbus-python
- dev-python/pygobject:3
- gnome-base/gconf
- gnome-extra/zenity
- libnotify? ( x11-libs/libnotify )
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:0= )
- media-libs/alsa-lib
- media-libs/fontconfig
- media-libs/harfbuzz
- media-libs/mesa
- net-misc/curl[ssl]
- net-print/cups[ssl]
- || ( media-sound/pulseaudio media-sound/apulse )
- systray? ( gnome-extra/gnome-integration-spotify )
- x11-libs/gtk+:2
- x11-libs/libXScrnSaver
- x11-libs/libXtst
-"
- #sys-libs/glibc
-
-S=${WORKDIR}/
-
-QA_PREBUILT="opt/spotify/spotify-client/spotify"
-
-src_prepare() {
- # Fix desktop entry to launch spotify-dbus.py for systray integration
- if use systray ; then
- sed -i \
- -e 's/spotify \%U/spotify-dbus.py \%U/g' \
- usr/share/spotify/spotify.desktop || die "sed failed"
- fi
- default
-
- # Spotify links against libcurl-gnutls.so.4, which does not exist in Gentoo.
- patchelf --replace-needed libcurl-gnutls.so.4 libcurl.so.4 usr/bin/spotify \
- || die "failed to patch libcurl library dependency"
-}
-
-src_install() {
- gunzip usr/share/doc/spotify-client/changelog.gz || die
- dodoc usr/share/doc/spotify-client/changelog
-
- SPOTIFY_PKG_HOME=usr/share/spotify
- insinto /usr/share/pixmaps
- doins ${SPOTIFY_PKG_HOME}/icons/*.png
-
- # install in /opt/spotify
- SPOTIFY_HOME=/opt/spotify/spotify-client
- insinto ${SPOTIFY_HOME}
- doins -r ${SPOTIFY_PKG_HOME}/*
- fperms +x ${SPOTIFY_HOME}/spotify
-
- dodir /usr/bin
- cat <<-EOF >"${D}"/usr/bin/spotify || die
- #! /bin/sh
- LD_LIBRARY_PATH="/usr/$(get_libdir)/apulse" \\
- exec ${SPOTIFY_HOME}/spotify "\$@"
- EOF
- fperms +x /usr/bin/spotify
-
- local size
- for size in 16 22 24 32 48 64 128 256 512; do
- newicon -s ${size} "${S}${SPOTIFY_PKG_HOME}/icons/spotify-linux-${size}.png" \
- "spotify-client.png"
- done
- domenu "${S}${SPOTIFY_PKG_HOME}/spotify.desktop"
- if use pax_kernel; then
- #create the headers, reset them to default, then paxmark -m them
- pax-mark C "${ED}${SPOTIFY_HOME}/${PN}" || die
- pax-mark z "${ED}${SPOTIFY_HOME}/${PN}" || die
- pax-mark m "${ED}${SPOTIFY_HOME}/${PN}" || die
- eqawarn "You have set USE=pax_kernel meaning that you intend to run"
- eqawarn "${PN} under a PaX enabled kernel. To do so, we must modify"
- eqawarn "the ${PN} binary itself and this *may* lead to breakage! If"
- eqawarn "you suspect that ${PN} is being broken by this modification,"
- eqawarn "please open a bug."
- fi
-}
-
-pkg_postinst() {
- xdg_pkg_postinst
-
- ewarn "If Spotify crashes after an upgrade its cache may be corrupt."
- ewarn "To remove the cache:"
- ewarn "rm -rf ~/.cache/spotify"
-}