summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/qastools/qastools-0.22.0.ebuild')
-rw-r--r--media-sound/qastools/qastools-0.22.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/media-sound/qastools/qastools-0.22.0.ebuild b/media-sound/qastools/qastools-0.22.0.ebuild
new file mode 100644
index 000000000000..9867792640f0
--- /dev/null
+++ b/media-sound/qastools/qastools-0.22.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Qt5 GUI ALSA tools: mixer, configuration browser"
+HOMEPAGE="https://gitlab.com/sebholt/qastools"
+SRC_URI="https://gitlab.com/sebholt/${PN}/-/archive/v${PV}/${PN}-v${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+"
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ media-libs/alsa-lib
+ virtual/libudev:=
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}-qt-5.15.patch" )
+
+S="${WORKDIR}"/${PN}-v${PV}
+
+src_configure() {
+ local mycmakeargs=(
+ -DSKIP_LICENSE_INSTALL=ON
+ )
+ cmake_src_configure
+}