summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-06-08 11:36:01 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-06-08 11:52:08 +0200
commit523b5b8bc049a8edb380c063b78d6016efd6dd52 (patch)
tree3bc94193df15b002d4e49be9520ef5b4b3571134 /media-sound/qastools/qastools-0.22.0.ebuild
parentx11-misc/zim: Old (diff)
downloadgentoo-523b5b8bc049a8edb380c063b78d6016efd6dd52.tar.gz
gentoo-523b5b8bc049a8edb380c063b78d6016efd6dd52.tar.bz2
gentoo-523b5b8bc049a8edb380c063b78d6016efd6dd52.zip
media-sound/qastools: 0.22.0 version bump, EAPI-7 bump, Qt 5.15 fix
Project moved to GitLab. - Update HOMEPAGE Upstream commit 4c24e5b98056f2d913845da6f034d22e2a817051 - Update LICENSE (switched from GPL-3 to MIT) Upstream commit 752a7d4d1e1ae888ed45785093df1387809fd15c Closes: https://bugs.gentoo.org/727350 Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-sound/qastools/qastools-0.22.0.ebuild')
-rw-r--r--media-sound/qastools/qastools-0.22.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/media-sound/qastools/qastools-0.22.0.ebuild b/media-sound/qastools/qastools-0.22.0.ebuild
new file mode 100644
index 000000000000..9867792640f0
--- /dev/null
+++ b/media-sound/qastools/qastools-0.22.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Qt5 GUI ALSA tools: mixer, configuration browser"
+HOMEPAGE="https://gitlab.com/sebholt/qastools"
+SRC_URI="https://gitlab.com/sebholt/${PN}/-/archive/v${PV}/${PN}-v${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+"
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ media-libs/alsa-lib
+ virtual/libudev:=
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}-qt-5.15.patch" )
+
+S="${WORKDIR}"/${PN}-v${PV}
+
+src_configure() {
+ local mycmakeargs=(
+ -DSKIP_LICENSE_INSTALL=ON
+ )
+ cmake_src_configure
+}