summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/ncmpcpp')
-rw-r--r--media-sound/ncmpcpp/Manifest2
-rw-r--r--media-sound/ncmpcpp/metadata.xml37
-rw-r--r--media-sound/ncmpcpp/ncmpcpp-0.6.4.ebuild65
-rw-r--r--media-sound/ncmpcpp/ncmpcpp-0.6.5.ebuild65
-rw-r--r--media-sound/ncmpcpp/ncmpcpp-9999.ebuild67
5 files changed, 236 insertions, 0 deletions
diff --git a/media-sound/ncmpcpp/Manifest b/media-sound/ncmpcpp/Manifest
new file mode 100644
index 000000000000..d8b915f3aa88
--- /dev/null
+++ b/media-sound/ncmpcpp/Manifest
@@ -0,0 +1,2 @@
+DIST ncmpcpp-0.6.4.tar.bz2 429705 SHA256 757e2e06b7e17009c24e2b46a69f008e61aa679476f93e00dc602ca087c805f1 SHA512 c60a6c2c89a9297d73360ec8819e8ae66ca53090c5ea5d3daf235e708467ee20006b1fff344c9312ccb0941c8307f3d84bcdc9cbf500955c74b10bd6a823c19f WHIRLPOOL 56bd22148f38289030a558b43008f83e9e0ccd1ff178be183ad935d08b397de51c49f2c7d84ab9504b62b0105516f460ff131d65a99af9e73519783e15c84797
+DIST ncmpcpp-0.6.5.tar.bz2 429699 SHA256 51128f6835c592c8d4367a66b08e06a9419a86c9d5c6e91d0f1dc73af56cd1fd SHA512 b120bd3c0697d51755e04908d29ddd4180ae662d3f02d60e967ccbefca87471eaf0dcf4ebed5d76203b7a0a6dd17a397f318a65087c1b8ec1e3fb4178964e581 WHIRLPOOL c4fa51645de9f1c7a530ee06113bc0fce5954d155112de4921dec2af5da58465b646c193f8359708b51619ec5f0fc9968680ec22549f97352f9309006499c77b
diff --git a/media-sound/ncmpcpp/metadata.xml b/media-sound/ncmpcpp/metadata.xml
new file mode 100644
index 000000000000..9a964f39fa16
--- /dev/null
+++ b/media-sound/ncmpcpp/metadata.xml
@@ -0,0 +1,37 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+ <maintainer>
+ <email>jer@gentoo.org</email>
+ </maintainer>
+ <maintainer>
+ <email>wired@gentoo.org</email>
+ <name>Alex Alexander</name>
+ </maintainer>
+ <use>
+ <flag name='clock'>Enable clock screen</flag>
+ <flag name='outputs'>Enable outputs screen</flag>
+ <flag name='visualizer'>Enable visualizer screen with sound wave/frequency
+ spectrum modes</flag>
+ </use>
+ <longdescription lang="en">
+ A featureful <pkg>sys-libs/ncurses</pkg> based <pkg>media-sound/mpd</pkg>
+ client inspired by <pkg>media-sound/ncmpc</pkg>
+
+ Ncmpcpp is very similar to ncmpc if it comes to user interface, but it
+ provides a lot of new useful features.
+
+ Main new features:
+ * tag editor
+ * playlist editor
+ * easy to use search engine
+ * media library
+ * music visualizer
+ * ability to fetch artist info from last.fm
+ * new display mode
+ * alternative user interface
+ * ability to browse and add files from outside of MPD music directory
+ ..and a lot more minor convenient functions.
+ </longdescription>
+</pkgmetadata>
diff --git a/media-sound/ncmpcpp/ncmpcpp-0.6.4.ebuild b/media-sound/ncmpcpp/ncmpcpp-0.6.4.ebuild
new file mode 100644
index 000000000000..e0caa2bc6ca3
--- /dev/null
+++ b/media-sound/ncmpcpp/ncmpcpp-0.6.4.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils
+
+DESCRIPTION="featureful ncurses based MPD client inspired by ncmpc"
+HOMEPAGE="http://ncmpcpp.rybczak.net/"
+SRC_URI="http://ncmpcpp.rybczak.net/stable/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 arm hppa ppc ppc64 sparc x86"
+IUSE="clock curl outputs taglib unicode visualizer"
+
+RDEPEND="
+ >=media-libs/libmpdclient-2.1
+ curl? ( net-misc/curl )
+ dev-libs/boost:=[nls,threads]
+ sys-libs/ncurses[unicode?]
+ sys-libs/readline:*
+ taglib? ( media-libs/taglib )
+ visualizer? ( sci-libs/fftw:3.0 )
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ sed -i -e '/^docdir/d' {,doc/}Makefile{.am,.in} || die
+ sed -i -e 's|COPYING||g' Makefile{.am,.in} || die
+}
+
+src_configure() {
+ econf \
+ $(use_enable clock) \
+ $(use_enable outputs) \
+ $(use_enable unicode) \
+ $(use_enable visualizer) \
+ $(use_with curl) \
+ $(use_with taglib) \
+ $(use_with visualizer fftw) \
+ --docdir=/usr/share/doc/${PF}
+}
+
+src_install() {
+ default
+
+ dodoc doc/{bindings,config}
+}
+
+pkg_postinst() {
+ echo
+ elog "Example configuration files have been installed at"
+ elog "${ROOT}usr/share/doc/${PF}"
+ elog "${P} uses ~/.ncmpcpp/config and ~/.ncmpcpp/bindings"
+ elog "as user configuration files."
+ echo
+ if use visualizer; then
+ elog "If you want to use the visualizer, you need mpd with fifo enabled."
+ echo
+ fi
+}
diff --git a/media-sound/ncmpcpp/ncmpcpp-0.6.5.ebuild b/media-sound/ncmpcpp/ncmpcpp-0.6.5.ebuild
new file mode 100644
index 000000000000..fae8b4835a42
--- /dev/null
+++ b/media-sound/ncmpcpp/ncmpcpp-0.6.5.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils
+
+DESCRIPTION="featureful ncurses based MPD client inspired by ncmpc"
+HOMEPAGE="http://ncmpcpp.rybczak.net/"
+SRC_URI="http://ncmpcpp.rybczak.net/stable/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="clock curl outputs taglib unicode visualizer"
+
+RDEPEND="
+ >=media-libs/libmpdclient-2.1
+ curl? ( net-misc/curl )
+ dev-libs/boost:=[nls,threads]
+ sys-libs/ncurses[unicode?]
+ sys-libs/readline:*
+ taglib? ( media-libs/taglib )
+ visualizer? ( sci-libs/fftw:3.0 )
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ sed -i -e '/^docdir/d' {,doc/}Makefile{.am,.in} || die
+ sed -i -e 's|COPYING||g' Makefile{.am,.in} || die
+}
+
+src_configure() {
+ econf \
+ $(use_enable clock) \
+ $(use_enable outputs) \
+ $(use_enable unicode) \
+ $(use_enable visualizer) \
+ $(use_with curl) \
+ $(use_with taglib) \
+ $(use_with visualizer fftw) \
+ --docdir=/usr/share/doc/${PF}
+}
+
+src_install() {
+ default
+
+ dodoc doc/{bindings,config}
+}
+
+pkg_postinst() {
+ echo
+ elog "Example configuration files have been installed at"
+ elog "${ROOT}usr/share/doc/${PF}"
+ elog "${P} uses ~/.ncmpcpp/config and ~/.ncmpcpp/bindings"
+ elog "as user configuration files."
+ echo
+ if use visualizer; then
+ elog "If you want to use the visualizer, you need mpd with fifo enabled."
+ echo
+ fi
+}
diff --git a/media-sound/ncmpcpp/ncmpcpp-9999.ebuild b/media-sound/ncmpcpp/ncmpcpp-9999.ebuild
new file mode 100644
index 000000000000..d1775b6eddd6
--- /dev/null
+++ b/media-sound/ncmpcpp/ncmpcpp-9999.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools eutils git-r3
+
+DESCRIPTION="featureful ncurses based MPD client inspired by ncmpc"
+HOMEPAGE="http://ncmpcpp.rybczak.net/"
+EGIT_REPO_URI="git://repo.or.cz/ncmpcpp.git"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS=""
+IUSE="clock curl outputs taglib unicode visualizer"
+
+RDEPEND="
+ >=media-libs/libmpdclient-2.1
+ curl? ( net-misc/curl )
+ dev-libs/boost:=[nls,threads]
+ sys-libs/ncurses[unicode?]
+ sys-libs/readline:*
+ taglib? ( media-libs/taglib )
+ visualizer? ( sci-libs/fftw:3.0 )
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ sed -i -e '/^docdir/d' {,doc/}Makefile.am || die
+ sed -i -e 's|COPYING||g' Makefile.am || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable clock) \
+ $(use_enable outputs) \
+ $(use_enable unicode) \
+ $(use_enable visualizer) \
+ $(use_with curl) \
+ $(use_with taglib) \
+ $(use_with visualizer fftw) \
+ --docdir=/usr/share/doc/${PF}
+}
+
+src_install() {
+ default
+
+ dodoc doc/{bindings,config}
+}
+
+pkg_postinst() {
+ echo
+ elog "Example configuration files have been installed at"
+ elog "${ROOT}usr/share/doc/${PF}"
+ elog "${P} uses ~/.ncmpcpp/config and ~/.ncmpcpp/bindings"
+ elog "as user configuration files."
+ echo
+ if use visualizer; then
+ elog "If you want to use the visualizer, you need mpd with fifo enabled."
+ echo
+ fi
+}