summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-kids')
-rw-r--r--games-kids/gmult/Manifest1
-rw-r--r--games-kids/gmult/gmult-12.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/games-kids/gmult/Manifest b/games-kids/gmult/Manifest
index e609bd66bcf3..5411cef899ae 100644
--- a/games-kids/gmult/Manifest
+++ b/games-kids/gmult/Manifest
@@ -1 +1,2 @@
DIST gmult-10.0.tar.xz 186116 BLAKE2B 0c3936983e1c6e72de7aa4056abdb1ec53af282d3927ca34a622d531966adc62e2e9c6740ab6c0cb3cfc9aedc21344c8866c5a2388498bd97c0faa3d32fae80b SHA512 f3eb639d4d6a67ca7d11595f0c4d4c2da613a95714f647536485fef4b64d277bf6f5bf163e363da691806b53ea885c56844287fe943fd521f995c7cce18b6a36
+DIST gmult-12.0.tar.bz2 195103 BLAKE2B d1d93190a607dc62bf4809dff7c5240c97f49dc4c833ea91028e9810961125eadba6fac41852b53f674b14c1e4c777a8d9ed58496ad2641ad99ed961041c40c8 SHA512 617b51defaf61c7967c9ccd6898209330733709df4290717e6c158719d04c61a38fa6832197c937f8aef1da23dc2f820c707291761ef8437ab0e78850253768c
diff --git a/games-kids/gmult/gmult-12.0.ebuild b/games-kids/gmult/gmult-12.0.ebuild
new file mode 100644
index 000000000000..b2b12394e1db
--- /dev/null
+++ b/games-kids/gmult/gmult-12.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome2-utils meson vala xdg
+
+DESCRIPTION="Multiplication Puzzle emulates the multiplication game found in Emacs"
+HOMEPAGE="https://gitlab.gnome.org/mterry/gmult/"
+SRC_URI="https://gitlab.gnome.org/mterry/gmult/-/archive/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-3+ CC-BY-SA-4.0 CC0-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="test" # only used for unnecessary .desktop/.po validation
+
+RDEPEND="
+ dev-libs/glib:2
+ >=gui-libs/gtk-4.10:4[introspection]
+ >=gui-libs/libadwaita-1.3:1[vala]
+ virtual/libintl
+ x11-libs/cairo
+ x11-libs/pango"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ $(vala_depend)
+ sys-devel/gettext"
+
+DOCS=( NEWS.md README.md )
+
+src_configure() {
+ vala_setup
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}