summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-tcltk/tclpython/tclpython-5.0.ebuild')
-rw-r--r--dev-tcltk/tclpython/tclpython-5.0.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/dev-tcltk/tclpython/tclpython-5.0.ebuild b/dev-tcltk/tclpython/tclpython-5.0.ebuild
new file mode 100644
index 000000000000..e4a170a603e8
--- /dev/null
+++ b/dev-tcltk/tclpython/tclpython-5.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit multilib python-single-r1 toolchain-funcs
+
+DESCRIPTION="Python package for Tcl"
+HOMEPAGE="http://jfontain.free.fr/tclpython.htm"
+SRC_URI="https://github.com/amykyta3/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ dev-lang/tcl:0="
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
+
+src_compile() {
+ local PKG_NAME
+ if python_is_python3; then
+ PKG_NAME=tclpython3
+ else
+ PKG_NAME=tclpython
+ fi
+ emake PKG_NAME=${PKG_NAME} CC=$(tc-getCC)
+}
+
+src_install() {
+ if python_is_python3; then
+ insinto /usr/$(get_libdir)
+ doins -r build/tclpython3/tclpython3
+ fperms 775 /usr/$(get_libdir)/tclpython3/tclpython3.so.${PV}
+ dosym tclpython3.so.${PV} /usr/$(get_libdir)/tclpython3/tclpython3.so
+ else
+ insinto /usr/$(get_libdir)
+ doins -r build/tclpython/tclpython
+ fperms 775 /usr/$(get_libdir)/tclpython/tclpython.so.${PV}
+ dosym tclpython.so.${PV} /usr/$(get_libdir)/tclpython/tclpython3.so
+ fi
+
+ dodoc README.md VERSION.md
+}