summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/rosmsg/rosmsg-1.15.9.ebuild')
-rw-r--r--dev-ros/rosmsg/rosmsg-1.15.9.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/dev-ros/rosmsg/rosmsg-1.15.9.ebuild b/dev-ros/rosmsg/rosmsg-1.15.9.ebuild
index c750959458b6..a1986af34a32 100644
--- a/dev-ros/rosmsg/rosmsg-1.15.9.ebuild
+++ b/dev-ros/rosmsg/rosmsg-1.15.9.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -21,11 +21,13 @@ RDEPEND="
dev-ros/rosbag[${PYTHON_SINGLE_USEDEP}]
"
DEPEND="${RDEPEND}
- test? ( dev-ros/test_rosmaster[${PYTHON_SINGLE_USEDEP}] )
+ test? (
+ dev-ros/test_rosmaster[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/diagnostic_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ )
"
-PATCHES=( "${FILESDIR}/duplicates.patch" )
src_test() {
- export ROS_PACKAGE_PATH="${S}/../../:${ROS_PACKAGE_PATH}"
+ export ROS_PACKAGE_PATH="${S}:${EPREFIX}/usr/share/ros_packages/diagnostic_msgs"
ros-catkin_src_test
}