summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/zeroconf/zeroconf-0.24.4.ebuild')
-rw-r--r--dev-python/zeroconf/zeroconf-0.24.4.ebuild38
1 files changed, 0 insertions, 38 deletions
diff --git a/dev-python/zeroconf/zeroconf-0.24.4.ebuild b/dev-python/zeroconf/zeroconf-0.24.4.ebuild
deleted file mode 100644
index 670067cd5c12..000000000000
--- a/dev-python/zeroconf/zeroconf-0.24.4.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Pure Python Multicast DNS Service Discovery Library (Bonjour/Avahi compatible)"
-HOMEPAGE="https://github.com/jstasiak/python-zeroconf https://pypi.org/project/zeroconf/"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-
-RDEPEND="dev-python/ifaddr[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/nose[${PYTHON_USEDEP}]
- )"
-
-# Not included
-RESTRICT="test"
-
-python_prepare_all() {
- # It's virtual/python-enum34
- sed \
- -e "s:'enum-compat',::g" \
- -i setup.py || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- nosetests --verbose || die
-}