summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyxattr')
-rw-r--r--dev-python/pyxattr/Manifest2
-rw-r--r--dev-python/pyxattr/files/pyxattr-0.5.1-test-bytes.patch19
-rw-r--r--dev-python/pyxattr/metadata.xml16
-rw-r--r--dev-python/pyxattr/pyxattr-0.5.3.ebuild53
-rw-r--r--dev-python/pyxattr/pyxattr-0.5.5.ebuild56
-rw-r--r--dev-python/pyxattr/pyxattr-9999.ebuild40
6 files changed, 186 insertions, 0 deletions
diff --git a/dev-python/pyxattr/Manifest b/dev-python/pyxattr/Manifest
new file mode 100644
index 000000000000..3a777bc01298
--- /dev/null
+++ b/dev-python/pyxattr/Manifest
@@ -0,0 +1,2 @@
+DIST pyxattr-0.5.3.tar.gz 25977 SHA256 c395b34707506aa4e74da4930efaec9bb84bd652d8459de5b603bb8dc8b1d585 SHA512 ac1aa227ab9980e0b05bf71ac4466e8747791a0d5ea30d404359526ca32e6846ad9d4ef72208ff9c7a8208d91ffa309feebe7eab818ef2dc3ae1a5e9414ffeaa WHIRLPOOL 905076e9917d8eb8f78a564d31dfe7c649cd459106513dea53985eb026a144dfbaf062992786f63b799ec7410eec9dbc3f4ae9c41cbb7e1ec61f769c81fa6898
+DIST pyxattr-0.5.5.tar.gz 26718 SHA256 132297c35261dd74b2ae2bd558e725b04834bbdf60997495e0110e255f5f2a3f SHA512 77b732a7e524a7c31a0511df2c96c18b214f93c6ac47276ecdf12ed95133ee506fa882b2532a7159aa2f4e02a7128e33bb8883ea632a5394297d98fb28898327 WHIRLPOOL 42db6c0d603f5bfca951a39194e5b95d4285a68b4c5e3f77ffe806fb5f05e46ce2f12dadc2d598c40178b68b83ee947b50474c7c026dc8e40378fc9c552a5180
diff --git a/dev-python/pyxattr/files/pyxattr-0.5.1-test-bytes.patch b/dev-python/pyxattr/files/pyxattr-0.5.1-test-bytes.patch
new file mode 100644
index 000000000000..6ff4bd052218
--- /dev/null
+++ b/dev-python/pyxattr/files/pyxattr-0.5.1-test-bytes.patch
@@ -0,0 +1,19 @@
+commit ea7421018090b7099c5e0a6bd88180f41ebb7bce
+Author: Mike Gilbert <floppym@gentoo.org>
+Date: Fri Dec 21 16:33:18 2012 -0500
+
+ Python 2.5 can't parse byte literals, so use bytes() instead.
+
+diff --git a/test/test_xattr.py b/test/test_xattr.py
+index 8df00b9..0bca576 100644
+--- a/test/test_xattr.py
++++ b/test/test_xattr.py
+@@ -12,7 +12,7 @@ from xattr import NS_USER, XATTR_CREATE, XATTR_REPLACE
+
+ if sys.hexversion >= 0x03000000:
+ PY3K = True
+- EMPTY_NS = b''
++ EMPTY_NS = bytes()
+ else:
+ PY3K = False
+ EMPTY_NS = ''
diff --git a/dev-python/pyxattr/metadata.xml b/dev-python/pyxattr/metadata.xml
new file mode 100644
index 000000000000..be6ec1870e53
--- /dev/null
+++ b/dev-python/pyxattr/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <longdescription>
+ pyxattr is an Python extension module wrapper for libattr. You can
+ use this module to query, list, add and remove extended attributes
+ from files and directories
+</longdescription>
+ <maintainer>
+ <email>robbat2@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">pyxattr</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pyxattr/pyxattr-0.5.3.ebuild b/dev-python/pyxattr/pyxattr-0.5.3.ebuild
new file mode 100644
index 000000000000..aef674e1cd6c
--- /dev/null
+++ b/dev-python/pyxattr/pyxattr-0.5.3.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Python interface to xattr"
+HOMEPAGE="http://pyxattr.k1024.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz
+ http://pyxattr.k1024.org/downloads/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-linux ~arm-linux ~x86-linux"
+IUSE="doc test"
+
+RDEPEND="sys-apps/attr"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( <dev-python/sphinx-1.3[${PYTHON_USEDEP}] )
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ sed -i -e 's:, "-Werror"::' setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake doc
+}
+
+src_test() {
+ # Perform the tests in /var/tmp; that location is more likely
+ # to have xattr support than /tmp which is often tmpfs.
+ export TESTDIR=/var/tmp
+
+ einfo 'Please note that the tests fail if xattrs are not supported'
+ einfo 'by the filesystem used for /var/tmp.'
+ distutils-r1_src_test
+}
+
+python_test() {
+ nosetests || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/pyxattr/pyxattr-0.5.5.ebuild b/dev-python/pyxattr/pyxattr-0.5.5.ebuild
new file mode 100644
index 000000000000..7d1bae346c2e
--- /dev/null
+++ b/dev-python/pyxattr/pyxattr-0.5.5.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Python interface to xattr"
+HOMEPAGE="http://pyxattr.k1024.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz
+ http://pyxattr.k1024.org/downloads/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~m68k ~mips ~ppc64 ~s390 ~sh ~x86 ~amd64-linux ~arm-linux ~x86-linux"
+IUSE="doc test"
+
+RDEPEND="sys-apps/attr"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( >=dev-python/sphinx-1.3.1[${PYTHON_USEDEP}] )
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ sed -i -e 's:, "-Werror"::' setup.py || die
+ # Bug 548486
+ sed -e "s:html_theme = 'default':html_theme = 'classic':" \
+ -i doc/conf.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake doc
+}
+
+src_test() {
+ # Perform the tests in /var/tmp; that location is more likely
+ # to have xattr support than /tmp which is often tmpfs.
+ export TESTDIR=/var/tmp
+
+ einfo 'Please note that the tests fail if xattrs are not supported'
+ einfo 'by the filesystem used for /var/tmp.'
+ distutils-r1_src_test
+}
+
+python_test() {
+ nosetests || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/pyxattr/pyxattr-9999.ebuild b/dev-python/pyxattr/pyxattr-9999.ebuild
new file mode 100644
index 000000000000..0935505fb938
--- /dev/null
+++ b/dev-python/pyxattr/pyxattr-9999.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1 eutils git-r3
+
+DESCRIPTION="Python interface to xattr"
+HOMEPAGE="http://pyxattr.k1024.org/"
+SRC_URI=""
+EGIT_REPO_URI="
+ https://github.com/iustin/${PN}.git
+ git://github.com/iustin/${PN}.git"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS=""
+IUSE="test"
+
+RDEPEND="sys-apps/attr"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+src_test() {
+ # Perform the tests in /var/tmp; that location is more likely
+ # to have xattr support than /tmp which is often tmpfs.
+ export TESTDIR=/var/tmp
+
+ einfo 'Please note that the tests fail if xattrs are not supported'
+ einfo 'by the filesystem used for /var/tmp.'
+ distutils-r1_src_test
+}
+
+python_test() {
+ nosetests || die "Tests fail with ${EPYTHON}"
+}