summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/mccabe/mccabe-0.5.2.ebuild')
-rw-r--r--dev-python/mccabe/mccabe-0.5.2.ebuild30
1 files changed, 0 insertions, 30 deletions
diff --git a/dev-python/mccabe/mccabe-0.5.2.ebuild b/dev-python/mccabe/mccabe-0.5.2.ebuild
deleted file mode 100644
index 37a609a9c6e4..000000000000
--- a/dev-python/mccabe/mccabe-0.5.2.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-
-inherit distutils-r1
-
-DESCRIPTION="flake8 plugin: McCabe complexity checker"
-HOMEPAGE="https://github.com/PyCQA/mccabe"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="test"
-LICENSE="MIT"
-SLOT="0"
-
-RDEPEND="dev-python/flake8[${PYTHON_USEDEP}]"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
-
-python_prepare_all() {
- sed -i -e '/pytest-runner/d' setup.py || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- py.test -v || die "Testing failed with ${EPYTHON}"
-}