summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/line_profiler/line_profiler-2.0.ebuild')
-rw-r--r--dev-python/line_profiler/line_profiler-2.0.ebuild31
1 files changed, 0 insertions, 31 deletions
diff --git a/dev-python/line_profiler/line_profiler-2.0.ebuild b/dev-python/line_profiler/line_profiler-2.0.ebuild
deleted file mode 100644
index b3890bb3863d..000000000000
--- a/dev-python/line_profiler/line_profiler-2.0.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="Line-by-line profiler"
-HOMEPAGE="
- https://github.com/rkern/line_profiler
- https://pypi.org/project/line_profiler/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-KEYWORDS="~amd64"
-
-SLOT="0"
-LICENSE="BSD"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="dev-python/ipython[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )
- "
-
-python_test() {
- "${EPYTHON}" -m unittest discover -v "${S}"/tests/ \
- || die "Tests failed with ${EPYTHON}"
-}